X
Tap here to go to the mobile version of the site.

Support Forum

firefox does not work with my simple http server

Posted

I'm developing a simple http server. I can generate simple HTTP responses. IE displays the response properly; FF does not.

Here is the response:

       "HTTP/1.1 200 OK\r\n" \

"Host: 127.0.0.1:80\r\n" \ "Date: %s\r\n" \ "Server: SimpleHTTPtutorial v0 %d\r\n" \ "Content-Type: text/html\r\n" \ "Content-Length: 44; charset=ISO-8859-1\r\n" \ "\r\n" \ "blahblah from %d

Does FF require something extra in order to interpret a page? FF responds with a blank page or says the connection was reset.

I'm developing a simple http server. I can generate simple HTTP responses. IE displays the response properly; FF does not. Here is the response: "HTTP/1.1 200 OK\r\n" \ "Host: 127.0.0.1:80\r\n" \ "Date: %s\r\n" \ "Server: SimpleHTTPtutorial v0 %d\r\n" \ "Content-Type: text/html\r\n" \ "Content-Length: 44; charset=ISO-8859-1\r\n" \ "\r\n" \ "<html><body>blahblah from %d</body></html> Does FF require something extra in order to interpret a page? FF responds with a blank page or says the connection was reset.

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-In 3.0.1.0
  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 11.0 r1
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • 4.0.60831.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.24) Gecko/20111103 Firefox/3.6.24

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12897 solutions 118323 answers

Looks that the content didn't get processed before it got send, i.e. convert "\r" to CR and "\n" to LF and substituting the %s and %d.


A good place to ask advice about web development is at the mozillaZine Web Development/Standards Evangelism forum.
The helpers at that forum are more knowledgeable about web development issues.
You need to register at the mozillaZine forum site in order to post at that forum.

See http://forums.mozillazine.org/viewforum.php?f=25

Looks that the content didn't get processed before it got send, i.e. convert "\r" to CR and "\n" to LF and substituting the %s and %d. ---- A good place to ask advice about web development is at the mozillaZine Web Development/Standards Evangelism forum.<br /> The helpers at that forum are more knowledgeable about web development issues.<br /> You need to register at the mozillaZine forum site in order to post at that forum. See http://forums.mozillazine.org/viewforum.php?f=25