X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

repeated untrusted connection to gmail

Posted

I recently cleared my complete browsing history and cache. Now I keep getting "Untrusted Connection" when trying to connect to my gmail accounts. But I don't think that's true.

Chosen solution

Thank you, cippazza, that did the trick. It's curious, as the problem only arose after I cleared all of my recent history about a week ago, so I didn't think that that would resolve the issue. But it did. Very grateful to you for the input.

Read this answer in context 3

Additional System Details

Sites Affected

https://accounts.google.com/ServiceLogin?service=mail&passive=true&rm=false&continue=http%3A%2F%2Fmail.google.com%2Fmail%2F%3Fui%3Dhtml%26zy%3Dl&bsv=llya694le36z&scc=1&ltmpl=default&ltmplcache=2

Installed Plug-ins

  • http://www.facebook.com/fbplugin/
  • iPhoto6
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

This is the "error" message:
"This Connection is Untrusted
You have asked Firefox to connect securely to accounts.google.com, but we can't confirm that your connection is secure.
Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.
What Should I Do?
If you usually connect to
this site without problems, this error could mean that someone is
trying to impersonate the site, and you shouldn't continue.
Technical Details
accounts.google.com uses an invalid security certificate.
The certificate is not trusted because the issuer certificate is not trusted.
(Error code: sec_error_untrusted_issuer)"

cippazza 0 solutions 1 answers

Helpful Reply

I had the same issue and I solved it by deleting cache and site preferences . I know the people solved by deleting cert8.db inside the firefox profile folder.

bye

Modified by cippazza

Chosen Solution

Thank you, cippazza, that did the trick. It's curious, as the problem only arose after I cleared all of my recent history about a week ago, so I didn't think that that would resolve the issue. But it did. Very grateful to you for the input.

whisky_jack 0 solutions 1 answers

Thanks, cippazza. I had this problem after upgrading from Firefox 4 to 8. Changing the name of cert8.db in the user profile folder forced Firefox to rebuild cert8.db, which is much smaller and works!

Question owner

Hi whisky_jack Thanks for your input. I find that simply deleting the entire History does the trick – easy! What do you mean when you say, "Changing the name of cert8.db in the user profile folder forced Firefox to rebuild cert8.db, which is much smaller and works!"? And how would you do that?

Daenerys 0 solutions 1 answers

Hey MargaretInOban - Locate the cert8.db file in /Library/Application Support/Firefox/Profiles. With Firefox closed, rename (or just delete) the cert8.db file. The file will be recreated automatically next time you open Firefox. This solution worked for me and I noticed that the new file was only 25KB, smaller than the one I deleted that was 672KB.