Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have done the update to Firefox 7 yet when I open Firefox it tells me I need to update to the newest version which I just did, how can I fix this?

  • 6 replies
  • 29 have this problem
  • 4 views
  • Last reply by jim.ruppert

more options

I keep my Firefox up-to-date at all times but the last few weeks Gmail has been telling me that I am using an older version which it no longer supports even though I have the updated version. I was notified that Firefox could be updated to the newest version, which I did. After the update when I opened Firefox it told me that I needed to update to the newest version which I had already done. How can I fix this?

Chosen solution

Having two versions is one possibility. The other is that the user agent is stuck to the old Firefox 3.5.3 version due to a certain extension.

Check the general.useragent prefs on the about:config page. You can open the about:config page via the Location (address) bar, just like you open a website.

Filter: general.useragent

If any general.useragent prefs are bold (user set) then right-click that pref and choose Reset.


It may likely be due to the FBSMTWB on end of your useragent that the Fast Browser Search toolbar extension added on at some point and therefore made the Firefox version stuck. This issue was fixed as of Firefox 4.0.

Read this answer in context 👍 4

All Replies (6)

more options

It's looks like you are running Firefox 3.5.3 which isn't the latest version. You may have ended up with two versions installed somehow. Try:

  1. Downloading the latest version from http://mozilla.org/firefox but don't install it right away.
  2. Go to the uninstall program control panel and remove all versions of Firefox (don't remove your personal data).
  3. Install the latest version from the setup file you downloaded.
more options

Chosen Solution

Having two versions is one possibility. The other is that the user agent is stuck to the old Firefox 3.5.3 version due to a certain extension.

Check the general.useragent prefs on the about:config page. You can open the about:config page via the Location (address) bar, just like you open a website.

Filter: general.useragent

If any general.useragent prefs are bold (user set) then right-click that pref and choose Reset.


It may likely be due to the FBSMTWB on end of your useragent that the Fast Browser Search toolbar extension added on at some point and therefore made the Firefox version stuck. This issue was fixed as of Firefox 4.0.

more options

Your User Agent shows that you have the Fast Browser Search toolbar (Fast Browser Search Make The Web Better - FBSMTWB) installed.

-> go to Control Panel > Add or Remove Programs -> Uninstall these programs:

-> Delete these Files: fast-browser-search.xml, fbstoolbar.jar, fbstoolbar.manifest

See these pages and threads about Fast Browser Search (FBSMTWB in the user agent, Help > About)

Check and tell if its working.

more options

Thank you for all of the responses!! I did parts from each answer and it looks like the problem is now solved :) Thank you so much!!

more options

Glad to hear it

Modified by Hasan

more options

Resetting the Preferences worked. Thank You, Thank You

Modified by jim.ruppert