Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The 'http://' URL prefix is now hidden by default how do I set it to visable

  • 2 replies
  • 53 have this problem
  • 6889 views
  • Last reply by SafeBrowser

more options

With the FF 7 update can't see http:// how to set it back to the full address please

Chosen solution

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part.

Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config

  1. type about:config in the Location/URL/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = browser.urlbar.trimURLs
  4. double-click on the pref in the lower panel to toggle it to "false" OR right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false"
  5. close the about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.


Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

Read this answer in context 👍 32

All Replies (2)

more options

just found an answewr to my own question buried in bugzilla... for anybody else

about:config browser.urlbar.trimURLs=false gives back consistent and sane UI.

more options

Chosen Solution

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part.

Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config

  1. type about:config in the Location/URL/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = browser.urlbar.trimURLs
  4. double-click on the pref in the lower panel to toggle it to "false" OR right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false"
  5. close the about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.


Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary: