Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I enter Private Browsing, Firefox switches from Google to Bing. How do I stop this.

  • No replies
  • 1 has this problem
more options

Uninstalled Firefox, downloaded and installed new copy, and got the same result.