Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I updated firefox to 6.0.1 today now it will not open just ...XUL Runner..Error: Platform version '6.0' is not compatible with minVersion>=6.0.1 maxVersion<=6.0.1 Help please!!

  • 7 replies
  • 19 have this problem
  • 51 views
  • Last reply by cor-el

more options

They is no info this all is it shows on screen

Chosen solution

Are you using ZoneAlarm (Extreme)?
If you have then try to disable that and do a clean reinstall of Firefox.

The updater wasn't able to update all the files and some were left as older versions.

Download a fresh Firefox copy and save the file to the desktop.

  • Uninstall your current Firefox version.
  • Do not remove personal data when you uninstall the current version.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

Read this answer in context 👍 0

All Replies (7)

more options

Chosen Solution

Are you using ZoneAlarm (Extreme)?
If you have then try to disable that and do a clean reinstall of Firefox.

The updater wasn't able to update all the files and some were left as older versions.

Download a fresh Firefox copy and save the file to the desktop.

  • Uninstall your current Firefox version.
  • Do not remove personal data when you uninstall the current version.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

more options

Yes I am using ZoneAlarm Exterme, so i followed your answer...and all works fine now Thank you for your help......

more options

I am using Zone Alarm Extreme (ZA). I tried your solution seveal times. Got rid of all files related to Foxfire and still get the same error. I don't get the error as long as turn off ZA. I have gone in ZA an made sure Foxfire was being allowed by ZA. No success. I have spent so much time on this that I will pobabably just go to Explorer. Thanks

Modified by Froggie14

more options

Try to disable Virtualization.

See:

more options

Today the error has come back!!!!...How do you turn off virtualization in ZA

more options

That allowed me to install the program but if I want it to run, I have to shut down my security everytime otherwise I get the same message.

more options

Try to ask advice at the ZoneAlarm forum.