X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do a prevent web pages from auto reload with no warning?

Posted

Pages like www.drudgereoprt.com have code to auto refresh/reloads the page. This is annoying when your reading scrolled half way down the page and it reloads to the top and you loose your place on the page.

I have the warn on redirect set to true in the about:config but this does not prevent the the reload. Also I don't want to have a popup at the top of the page showing the warn on redirect warning because it just takes up another mouse drag and click to close that stolen real-estate. I want max window size and this popup just shrinks it down. Maybe there is an ad-on I havent found for this.

Additional System Details

Installed Plug-ins

  • Macromedia Authorware Web Player Netscape plug-in, version 2004
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • np-mswmp
  • 6.0.12.1662
  • RealJukebox Netscape Plugin
  • 1.7.0069.2
  • NPTURNMED
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

See:

  • Firefox/Tools > Options > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Tools > Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

Question owner

thanks, this does not answer my question. anybody else?

Donnie 31 solutions 331 answers

You can block websites from automatically reloading the page, this setting is grouped with the redirect setting also under accesibility features & by default is usually selected.

Firefox (Tools) > Options > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

If this option is not selected, then select it & when pages attempt to reload you will see a box appear on top right of toolbar just under search box saying allow or similar. If you want the page to reload auto then youll need to select allow, or turn it off. There is no way of getting around this as its all or nothing, but at-least its better than a popup.

Question owner

Like my original post and the next answer this option does not do it.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Sorry, my above post seemed to have ended up in the wrong thread as it obviously didn't have anything to do with your problem (well it might have been, but this is a known issue on the site).

The Drudge report site uses a JavaScript timer to reload the page.

There is a Greasemonkey script here to block the refresh

You can also use a bookmarklet like this to disable the reload (needs to be used if you reload the Drudge website)

javascript:clearInterval(timer);void(autoRefresh=null);

Question owner

thanks, Greasemonkey works great.