X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop Firefox from checking add-on compatibilty every time I start the program?

Posted

In the past 2 days, every time I start Firefox, a "What's New" tab (checking for compatibility of add-ons?) pops up in addition to my homepage tab. How can I keep the "What's New" tab from coming up? It seems like this starting happening after I updated to Firefox 6.0. Running Windows Vista Firefox 6.0

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Omnis Unicode RCC Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Delivery Network Acceleration by BitTorrentâ„¢
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • 4.0.60531.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

See:

Question owner

Thanks, but I've tried everything I could find in that article, and nothing is working! I might do like others and go back to 5.0.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Delete the files extensions.* (extensions.sqlite, extensions.ini, extensions.cache, extensions.rdf) and compatibility.ini in the Firefox profile folder to reset the extensions registry.
New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is an update.


Create a new profile as a test to check if your current profile is causing the problems.
See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

davejavu 0 solutions 1 answers

Helpful Reply

Firefox 8 i am on and its doing the same,very annoying,ill be going back to previous version...

do you guys at Firefox ever check your update's on any of your own computers before you release them?

might be a good idea,its the same with kylo,updates come screw everything up when they were working fine...im am a house builder,if i built houses with this many errors i'd be bankrupt by now....

Robba 0 solutions 1 answers

Sorry guys,

This problem has been around for more than a year. Had it since v7 and wasted many hours searching for a solution to no avail.

Just installed v8.0.1. and same issue. Always checks plugins even after I've disabled them. Then also keeps loading the Getting Started Tab as well.

These are old issues that I tried in vain to resolve more than six months ago. A real waste of time reading through all the ideas for hours to discover most are basically the same advice, or there is no solution to be found.

Have tried them all to no avail. Going back to Google Chrome I guess.

Chow

Robba

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Make sure that you do not have security software that restores files like compatibility.ini in the Firefox Profile Folder

Some security software have sandboxing or virtualization features.

Rigger56 0 solutions 1 answers

I have the same problem with the compatibility check and the "whatsnew" window opening with Firefox 10.0.2. I'm running XP ser pk. #3. I've tried to disable with the add-on manager and "options" and the changes are ignored. This is driving me nuts. I've never had problems with Firefox before but this is too much. I'm already using IE. Mozilla, please issue a real fix for this. Nothing I have tried solves the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Did you try the above posted suggestions?

See these articles for some suggestions:


Which security software (firewall, anti-virus) do you have?

Some security software has virtualization features that can cause problems by protecting and restoring files in the Firefox profile folder.

karipallu 0 solutions 2 answers

Helpful Reply

Pendekarlaut provided answer that worked for me:

1. Firefox orange button>help>Troubleshooting Information

2. Under Application Basics, click Open Containing Folder

3. there will be prefs.js, user.js and sessionstore.js

4. Delete all 3 files

5. restart and done.