X
Tap here to go to the mobile version of the site.

Support Forum

Bing has hijacked my browser interface. How do I get google back?

Posted

Bing has somehow sneaked onto the browser, probably when I installed new software. I am now missing some of the buttons I usually have replaced by the stupid bing toolbar. I hate bing, it is useless for me. Do I need to uninstall Firefox and reinstall it? I can't even find my bookmarks now. Other than Java and WOT, I don't usually have much in the way of plug-ins I use Win7 and Firefox 3 something

Bing has somehow sneaked onto the browser, probably when I installed new software. I am now missing some of the buttons I usually have replaced by the stupid bing toolbar. I hate bing, it is useless for me. Do I need to uninstall Firefox and reinstall it? I can't even find my bookmarks now. Other than Java and WOT, I don't usually have much in the way of plug-ins I use Win7 and Firefox 3 something

Chosen solution

I have the NoScript add-on ans used it to block Bing. I then used the "Manage Search Engines" option and removed Bing as a search option. The irritating browser hijack dialog box is gone (so far). Hope this helps

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • BitDefender QuickScan Web Netscape Plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.3 r181
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Google Update
  • Nitro PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18 SearchToolbar/1.2

More Information

David McRitchie 320 solutions 3091 answers

That one was done with a Microsoft update that incorrectly updated people not using Bing.


How to Remove Bing as Your Default Search Engine and Get Firefox to Work the Way it Used to | eHow.com

http://www.ehow.com/how_5196325_remove-firefox-work-way-used.html

http://kb.mozillazine.org/Keyword.URL

Removing the Search Helper Extension and Bing Bar | Troubleshooting | Firefox Help

http://support.mozilla.com/en-US/kb/Removing%20the%20Search%20Helper%20Extension%20and%20Bing%20Bar

Make Google.com or any other page your home page

https://support.mozilla.com/en-US/kb/How to set the home page

Tools > Options Security [x] Warn me when sites try to install add-ons [x] Block reported attack sites [x] Block reported web forgeries

That one was done with a Microsoft update that incorrectly updated people not using Bing. How to Remove Bing as Your Default Search Engine and Get Firefox to Work the Way it Used to | eHow.com :http://www.ehow.com/how_5196325_remove-firefox-work-way-used.html http://kb.mozillazine.org/Keyword.URL Removing the Search Helper Extension and Bing Bar | Troubleshooting | Firefox Help :http://support.mozilla.com/en-US/kb/Removing%20the%20Search%20Helper%20Extension%20and%20Bing%20Bar Make Google.com or any other page your home page :https://support.mozilla.com/en-US/kb/How to set the home page Tools > Options Security [x] Warn me when sites try to install add-ons [x] Block reported attack sites [x] Block reported web forgeries

Question owner

I was too impatient to wait and a quick Google search revealed that this is a very common problem. I found no one had posted the complete answer but a two step repair did the trick for me. If, like my situation, the standard Firefox Menu Buttons were missing, right-click on the icon in the left corner of the URL box and check the Menu Bar.

Step 1- Bring down Tools, choose "option" click on "General" which lets you choose how things start up. In my case, I wanted the default Firefox with Google page so I clicked "Restore to default".

Step 2- You still have the program that Bing installed, ready at the slightest excuse to take over again. So do not forget to uninstall the search bar for it . Bring up the Control Panel for Windows. Under Programs, uninstall the Bing search bar. There! Doesn't that feel better?

I was too impatient to wait and a quick Google search revealed that this is a very common problem. I found no one had posted the complete answer but a two step repair did the trick for me. If, like my situation, the standard Firefox Menu Buttons were missing, right-click on the icon in the left corner of the URL box and check the Menu Bar. Step 1- Bring down Tools, choose "option" click on "General" which lets you choose how things start up. In my case, I wanted the default Firefox with Google page so I clicked "Restore to default". Step 2- You still have the program that Bing installed, ready at the slightest excuse to take over again. So do not forget to uninstall the search bar for it . Bring up the Control Panel for Windows. Under Programs, uninstall the Bing search bar. There! Doesn't that feel better?
MoJo40Design 0 solutions 6 answers

Helpful Reply

Sometime Bing is not located in the Add/Remove programs section of the control panel.

6 Easy Steps to Remove Bing from Mozilla Firefox:

1. Click on the "inverted triangle" located to the right of the orange Bing icon.

2. Select the option "Manage Search Engines...". (A pop-up window will appear titled "Manage Search Engine List.)

3. Select "Bing".

4. Click the "Remove" button.

5. Select the desired search engine from the list.

6. Click "OK"

All Done.... :-)

Happy Searching...

Sometime Bing is not located in the Add/Remove programs section of the control panel. 6 Easy Steps to Remove Bing from Mozilla Firefox: 1. Click on the "inverted triangle" located to the right of the orange Bing icon. 2. Select the option "Manage Search Engines...". (A pop-up window will appear titled "Manage Search Engine List.) 3. Select "Bing". 4. Click the "Remove" button. 5. Select the desired search engine from the list. 6. Click "OK" All Done.... :-) Happy Searching...
MoJo40Design 0 solutions 6 answers
https://support.mozilla.com/en-US/kb/Search%20bar?s=bing&as=s
reshade 0 solutions 1 answers

Helpful Reply

I removed the bing install listed in the control panel Programs and Features (Win 7) (add/remove programs in XP) but that didn't remove the bing search from the Firefox(v6) toolbar. Went then to the Extensions selection in Add-ons. The only extension listed was something called StartNow. I selected to remove that extension and Bing disappeared from Firefox.

I removed the bing install listed in the control panel Programs and Features (Win 7) (add/remove programs in XP) but that didn't remove the bing search from the Firefox(v6) toolbar. Went then to the Extensions selection in Add-ons. The only extension listed was something called StartNow. I selected to remove that extension and Bing disappeared from Firefox.

Modified by reshade

honestbroker2 0 solutions 2 answers

When I opened a new tab the Bing search would be there. I removed this by using my Windows Explorer to go to C:Programs and looking for the StartNow folder. I opened the folder and found the uninstall application and used it. This removed the Bing search in a new tab.

When I opened a new tab the Bing search would be there. I removed this by using my Windows Explorer to go to C:Programs and looking for the StartNow folder. I opened the folder and found the uninstall application and used it. This removed the Bing search in a new tab.
dudleycorn 0 solutions 4 answers

This insidious bing was making me crazy too. After tryng some slutions posted here, I found an easy one for chrome. Right click in the address bar, click 'edit search providers', reset default!!!

This insidious bing was making me crazy too. After tryng some slutions posted here, I found an easy one for chrome. Right click in the address bar, click 'edit search providers', reset default!!!
scottykay 1 solutions 1 answers

Chosen Solution

I have the NoScript add-on ans used it to block Bing. I then used the "Manage Search Engines" option and removed Bing as a search option. The irritating browser hijack dialog box is gone (so far). Hope this helps

I have the NoScript add-on ans used it to block Bing. I then used the "Manage Search Engines" option and removed Bing as a search option. The irritating browser hijack dialog box is gone (so far). Hope this helps
jakamon 0 solutions 1 answers

When I hit HOME, it went to BING, even tho Firefox still knew home = Google. When I entered "www.google.com" in address bar, same thing, went to BING. Finally fixed by: > Control Panel > Internet Options > General (tab), Home Page ... Microsoft had set that www.go.bing.something or other Changed that back to "www.google.com" and problem fixed. Windows XP, Firefox browser, with home page set to google.com.

When I hit HOME, it went to BING, even tho Firefox still knew home = Google. When I entered "www.google.com" in address bar, same thing, went to BING. Finally fixed by: > Control Panel > Internet Options > General (tab), Home Page ... Microsoft had set that www.go.bing.something or other Changed that back to "www.google.com" and problem fixed. Windows XP, Firefox browser, with home page set to google.com.