Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox now always opens four tabs when I start it. (home page, plus three latest add-on updates)

  • 8 replies
  • 4 have this problem
  • 12 views
  • Last reply by Hasan

more options

I updated Firefox and all the add-ons. Since that time, Every time Firefox is opened, it always opens four tabs. One is my home page. One says Firefox has been updated. The other two are the notices for two add-ons that were updated.

It all began at the time I last updated my "Version-Three-Point-Something-Something..." I tried upgrading to the latest version of Firefox. This did not change my problem.

Thanks for your time. NS

Chosen solution

DELETE ALL LINES IN USER.JS FILE

User.js file overriding preferences

i started having the same problem when DownloadHelper updated to 4.9.4 and this method worked like a charm :-D

Checked and tell if its working for you.

Read this answer in context 👍 0

All Replies (8)

more options

How to set the home page

https://support.mozilla.com/en-US/kb/How%20to%20set%20the%20home%20page

Check and tell if its working.

more options

I have already tried that. Thanks.

From the article you suggested, I followed links to these help pages... "Firefox has just updated tab shows each time you start Firefox" and "Preferences are not saved"

I now suspect it is a corrupted preferences file.

I'll wait for a response from you, though, before I do anything. Thanks! NS

more options

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Tools Menu -> Options -> General -> When Firefox starts : select Show My Home Page and click Reset to Default button

If this does not work, Try the suggestions mentioned in this article:

Preferences are not saved

https://support.mozilla.com/en-US/kb/Preferences%20are%20not%20saved

Check and tell if it works.

Modified by Hasan

more options

I've tried all your suggestions. Thanks.

No change occurs when I try resetting the home page to "default." It still opens my home page www.google.com and those other tabs.

I tried the steps in the article. No change.

I've also tried removing the addons and reinstalling them. No changes - except that one or two fewer tabs pop up.

I have noticed that every restart of Firefox includes a "checking for compatibility of addons" pop-up. In Add-ons Manager, I can un-check the "Update Add-ons Automatically." Again, no change.

I was able to capture a few screen shots for you.

Thanks for your patience with me. NS

more options

Did you try to delete the file prefs.js in the Firefox Profile Folder?

See:

Help > Troubleshooting Information > Profile Directory: Open Containing Folder

more options

Chosen Solution

DELETE ALL LINES IN USER.JS FILE

User.js file overriding preferences

i started having the same problem when DownloadHelper updated to 4.9.4 and this method worked like a charm :-D

Checked and tell if its working for you.

more options

My problems seem to all be resolved since I followed the instructions on https://support.mozilla.com/en-US/kb/Preferences%20are%20not%20saved#w_user-js-file-overriding-preferences

I opened the user.js file with NOTEPAD. I "selected all" and deleted it, then saved the changes. When I restarted Firefox, it worked fine!!

Thanks for your help on this!!

more options

To help other users find solutions, please return to this Thread and Sign-in to the forum with your Username and Password:

click on "Solved It" next to the reply ABOVE that BEST solved your question

DO NOT click "Solved It" next to this reply