X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Error code: ssl_error_rx_record_too_long

Posted

I am having problem to open the website Gmail.com. I am getting this message when i try to open gmail.com.

Error code: ssl_error_rx_record_too_long

Additional System Details

Sites Affected

http://gmail.com

Installed Plug-ins

  • Shockwave Flash 10.2 r159
  • Fun Web Products Plugin Stub for 32-bit Windows
  • GEPlugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60531.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • My Web Search Plugin Stub for 32-bit Windows
  • 6.0.12.69
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • DRM Netscape Network Object
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

More Information

Xircal 334 solutions 3835 answers

You have two bits of adware installed which may be interrupting communication with Gmail. To remove these, do the following:

  1. Click the orange Firefox button and then click "Add-ons".

  2. Click the Plugins menu and disable the following:
  • Fun Web Products

  • My Web Search

Consider updating to the latest secure version of Firefox which you can download from here if the problem persists: http://www.mozilla.com/en-US/firefox/fx/?ref=logo

There's an explanation of the error you're seeing here: Secure Connection Failed


N.B. I noticed that several of your normal plugins are out of date which exposes your system to attack. You can check which ones you need to update by visiting the plugin check page here: http://www.mozilla.com/en-US/plugincheck/