X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Upgraded to Lion & can no longer finger swipe for/backwards between pages. Is there a fix for this?

Posted

Title says it all. I just upgraded to Mac OS X Lion, and can no longer use a finger swipe, whether one or 2 fingered, to move backwards an forwards between pages. I can still do so in Safari, but not in Firefox 5.01, my preferred browser, any longer. Doesn't matter if I try using one, two or more fingers

Is there a fix for this? Thank you.

Additional System Details

This happened

Every time Firefox opened

This started when...

Right after upgrading to Mac OS X Lion

Installed Plug-ins

  • Cooliris embbedded in a tab
  • Office Live Update v1.0
  • iPhoto6
  • View PDF documents within your web browser.
  • DivX Web Player version 2.0.2.39
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 4.0.50917.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r181

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

DrewMcW 0 solutions 3 answers

Helpful Reply

If you download this program http://blog.boastr.net/?page_id=1722 (better touch tool), you can make your own swipe gestures.

However, I have been able to three-finger swipe forward and back on webpages by going to system preferences > trackpad settings > more gestures and checking the box at "swipe between pages" and selecting swipe left/right with 3 fingers

Question owner

Thanks, Drew. Thing is that I'm using Lion only on my iMac right now, and, therefore, only the Apple wireless mouse. 3-finger swipes aren't an option for the mouse. When I get around to upgrading the Macbook Pro, then I'll see what options are available, as it'll be trackpad use then.

Question owner

Forgot to mention that, in the meanwhile, I discovered in Sys Prefs of Lion that I can choose to go with 2-finger swipes for changing pages, but I give up using swipes between open applications. That's okay with me because I've been using keyboard commands to switch apps, and prefer to swipe for page changes.

DrewMcW 0 solutions 3 answers

you could use better touch tool and make 2-finger swipe right/left gestures into shortcuts for: ⌘→; ⌘← respectively

Modified by DrewMcW

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8008 answers

All I can add is that Mozilla & Firefox are aware there are some issues with the release of Lion. Maybe watch other threads for news.

I am not a Mac user but maybe changing settings could help, but you may then loose some other feature. There are some technical reports linked from a contributors thread /forums/contributors/707160

flashmxpro 0 solutions 1 answers

Helpful Reply

I solved this issue by using those settings:

Trackpad -> More Gestures Swipe between pages = Swipe left or write with three fingers Swipe between full-screen apps = Swipe left or right with four fingers

Question owner

Yes, that’s fine when using a trackpad. However, on my Apple wireless mouse, 3 finger swipes are not an option. I’ve solved it by choosing to swipe back and forth between pages rather than Spaces. I’m happy to go thru applications via keyboard commands, as I use that less frequently than moving between pages.

styvwerx 0 solutions 1 answers

I was baffled by the loss of swipe forward/backward too, but try a FOUR (4) finger swipe, it works for me. I don't even see it listed in the trackpad options, (BTW, I LOVE the trackpad for the iMac), but it sure works!

timfarley 0 solutions 1 answers

I got flashmxpro's method to work as well. And I actually like it better because I use two finger for vertical scrolling and no longer accidentally navigate back/forward when trying to scroll down a page. This setting will work across other browsers (chrome, safari) as well...

Modified by timfarley

petervangalen 0 solutions 1 answers

I have been the most loyal Firefox supporter, telling everybody how great it is and making my family install it and all. Now that I got a Mac, I am realizing I have to switch to Safari, mainly because of this reason. It is very sad. Even with the Better Touch Tool it doesn't swipe as nicely in Firefox as in Safari (although I still recommend this app). Maybe I can switch back if this is fixed soon...

anthonyk 0 solutions 1 answers

This simple fix worked for me, hopefully it works for you too:

System Preferences --> Trackpad

"More Gestures" Tab

Change "Swipe between pages" to "Swipe with two or three fingers"

Change "Swipe between full-screen apps" to "swipe left or right with four fingers"

This way, it appears that you have your two-finger swipes in Safari, and your three-finger swipes back in Firefox.