Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

While on my Facebook profile I was seaI right clicked a profile photo and clicked 'view image info'. There I checked the box 'Block Images from external.ak.fbcdn.net'. Now hardly any profile photos display and I cannot find where to uncheck that box.

  • 4 replies
  • 72 have this problem
  • 106 views
  • Last reply by ngsteve

more options

While on Facebook with Firefox browser: I clicked on my work description I did a right click on that silly stock photo of a briefcase At bottom of popup box was choice 'view image info' I clicked on 'view image info' New popup box with image info I checked box 'Block Images from external.ak.fbcdn.net' I probably clicked box 'Save as'... I am not sure how I closed image info box Now the 'briefcase' profile image does not show but neither does my profile photo or friends profile photos.

How can I get back to that box to uncheck it? THANKS...

Chosen solution

Check the exceptions in Tools > Options > Content: Load Images > Exceptions

You can use these steps to check if images are blocked:

  • Click the "More Information" button to open the "Page Info" window with the Security tab selected (also accessible via "Tools > Page Info").
  • Go to the Media tab of the "Tools > Page Info" window.
  • Select the first image link and scroll down through the list with the Down arrow key.
  • If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.
Read this answer in context 👍 11

All Replies (4)

more options

Chosen Solution

Check the exceptions in Tools > Options > Content: Load Images > Exceptions

You can use these steps to check if images are blocked:

  • Click the "More Information" button to open the "Page Info" window with the Security tab selected (also accessible via "Tools > Page Info").
  • Go to the Media tab of the "Tools > Page Info" window.
  • Select the first image link and scroll down through the list with the Down arrow key.
  • If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.
more options

That worked like a charm. I found the image that had the 'Block...' check, unchecked it and profile photos display now. Tools, Page Info....

Thanks!

more options

You're welcome

more options

Thanks so much, I have got back my photos