Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No matter what I type in the awesome bar, it just redirects to the Google homepage.

  • 3 replies
  • 20 have this problem
  • 34 views
  • Last reply by Helper7677

more options

If I type a complete web address in the awesome bar, I go there. But if I type a search term, the text changes to http://www.google.com/webhp and I'm redirected to the Google home page every time.

Modified by nslator

Chosen solution

There is a change beginning in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site

To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference OR install the add-on below.

To change the preference:

  1. Type about:config into the location bar and press the Enter key
  2. If you see a warning, accept it (promise to be careful)
  3. A list of preferences will open
  4. Filter = keyword.URL
  5. Double-click on that preference in the lower pane
  6. A small window will appear; copy one of the URLs below and paste into the box in that small window (or type it into the box in that window exactly as shown below):

Instead of the above, you could install this extension:

See:




You have old versions of Java Console in Add-ons > Extensions that Java failed to "clean-up" when updating. You can easily and safely remove them.

  • Instructions: http://kb.mozillazine.org/Java#Multiple_Java_Console_extensions
  • Your old versions:
    • Java Console 6.0.17 {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
    • Java Console 6.0.19 {CAFEEFAC-0016-0000-0019-ABCDEFFEDCBA}
    • Java Console 6.0.20 {CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
    • Java Console 6.0.21 {CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}
    • Java Console 6.0.22 {CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
    • Java Console 6.0.23 {CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}




You need to update the following. The Plugin version(s) shown below was/were submitted with your question and is/are out of date. You should update to avoid known security issues with the version(s) you have installed. Click on "More system info..." to the right of your question to see what was included with your question.

  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  1. Check your plugin versions on either of the following links':
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update the Java plugin to the latest version.
Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

There is a change beginning in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site

To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference OR install the add-on below.

To change the preference:

  1. Type about:config into the location bar and press the Enter key
  2. If you see a warning, accept it (promise to be careful)
  3. A list of preferences will open
  4. Filter = keyword.URL
  5. Double-click on that preference in the lower pane
  6. A small window will appear; copy one of the URLs below and paste into the box in that small window (or type it into the box in that window exactly as shown below):

Instead of the above, you could install this extension:

See:




You have old versions of Java Console in Add-ons > Extensions that Java failed to "clean-up" when updating. You can easily and safely remove them.

  • Instructions: http://kb.mozillazine.org/Java#Multiple_Java_Console_extensions
  • Your old versions:
    • Java Console 6.0.17 {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
    • Java Console 6.0.19 {CAFEEFAC-0016-0000-0019-ABCDEFFEDCBA}
    • Java Console 6.0.20 {CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
    • Java Console 6.0.21 {CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}
    • Java Console 6.0.22 {CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
    • Java Console 6.0.23 {CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}




You need to update the following. The Plugin version(s) shown below was/were submitted with your question and is/are out of date. You should update to avoid known security issues with the version(s) you have installed. Click on "More system info..." to the right of your question to see what was included with your question.

  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  1. Check your plugin versions on either of the following links':
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update the Java plugin to the latest version.
more options

I re-enabled "browse by name" and that fixed the problem. Also, I updated all the programs and addons you mentioned -- I thought those things mostly took care of themselves. Thanks!

Modified by nslator

more options

Try the section "To change the preference". Your keyword.URL may be set incorrectly.