X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I revert back to older version of firefox?

Posted

Hi, I recenlty downloadee firefox 5 and found that most of the add ons are not working with this version of firefox and when tried to revert back to the older version, all my searches were redirected to firefox 5 page only. Please help in getting firefox 4. Thanks

Chosen solution

You can try this extension to override compatibility issues,

Once it is installed, open Addons Manager and re-enable the addons you like.

Addons Manager URL:    about:addons

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 10.2 r152
  • 4.0.60310.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

Gryllida 76 solutions 892 answers

Chosen Solution

You can try this extension to override compatibility issues,

Once it is installed, open Addons Manager and re-enable the addons you like.

Addons Manager URL:    about:addons

Question owner

Hi, Thanks. It almost solved my prob :)

Question owner

@Gryllida Can you please tell me as to how I can enable "save and exit" feature available with other version of Firefox in Firefox 5? Thanks

Gryllida 76 solutions 892 answers

Helpful Reply

amjath - please see How do I restore my tabs from last time? and make a new thread if this doesn't help. Thank you.

Question owner

Gryllida - Thank you for redirecting me to the right place! And thank you so much for all you help through. :)

DebbieKat 0 solutions 3 answers

Mozilla does not warn you that the new version can't be installed with particular versions of OSX and now I no longer have the ability to run Firefox at all. I need the older version.