X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Image type is missing from the the picture save dialog box.

Posted

When I right click a picture and select 'Save as', the picture type field is blank. This used to show an image type such as JPG, PNG, or GIF.

Additional System Details

This happened

Every time Firefox opened

This started when...

Sometime in the last 3 weeks (approx)

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Motive Plugin for Mozilla Browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

This does not happen with any other picture software or with Internet Explorer 8. Picture extensions are all set correctly in
My Computer -> Tools -> Folder Options -> File Types
I have tried turning off all addons, clearing cache, cookies and supercookies, cleaning the registry, and rebooting the machine. I have tried reinstalling Firefox and running it with a newly created profile. None of this rectified the situation.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

You can try "Reset Download Actions":

Corliya 1 solutions 48 answers

Also, are you clicking Save Link As... or Save Image As... & have you got the Save as type field underneath the File name field? If both are there & that window looks fine, then perhaps it's just some (javascript) script on that page that's changing things?.. Have you got an example (image) URL that we can look at?

Modified by Corliya

Question owner

@Corliya: If I right click on your Firefox avatar https://support.mozilla.com/media/uploads/avatars/2011-03-12-09-31-09-2e9a1e.gif

on this page, and then left click Save Image As ...,

in the list which appears I get: File name: 2011-03-12-09-31-09-2e9a1e_gif Save as type:

There is nothing after 'Save as type'. If I click the down arrow on the right of the 'Save as' name box, it colours the box blue, but does not reveal the image type.

It is only after saving the image that I discover from the file extension that it is JPG.

Modified by Rackbrane

Question owner

@Core-el: Neither of the fields: browser.download.pluginOverrideTypes plugin.disable_full_page_plugin_for_types appears in the about:config list.

I tried renaming mimeTypes.rdf, and on reloading Firefox I found a new one had been created.

However, it did not solve my problem.

elevencoin 0 solutions 1 answers

I just find a solution for this issue: 1. Open Control Panel - Folder Options - Change the file type associated with a file extension. 2. Select .jpg, then click "Change program..." 3. Reset the configuration to "Windows Photo Viewer". Now your firefox should works fine. Note the setting might be slightly different in XP or Vista.

Modified by elevencoin

Question owner

This doesn't work for me, I'm afraid. In any case, I don't wish to reassign jpg or any other extension to open with Windows Photo Viewer as default.

finitarry 157 solutions 2177 answers

When I save an image or a link, there is a "Format:" box near the bottom of the save window. That gives the file format. Does Windows Firefox not do that? Also, when you save a file, does the extension not appear at the end of the filename (e.g. avatar-37031.png or 837101.htm)?

Question owner

I get boxes labelled 'File name:' and 'Save as type:'. The file name is already filled in, and can be edited. The type field is blank, and cannot be changed or made visible.

The file type does get added to the end of the file name, but I would like to see what this is going to be before I save the image. Some web images don't save with the extension specified in the URL.

Everyone who has posted an image where this feature works seems to be using Windows 7. I am using XP SP3 Home Edition.

Although I was using Firefox 4.0.1 when I posted this fault report, I have now progressed through Firefox 5 and 6 to Firefox 7.0.1. The fault has persisted in all these versions.

Modified by Rackbrane

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Helpful Reply

I found these bug reports but they don't offer a solution:

You said, The file type does get added to the end of the file name. so try this:
From the "Tools" menu in Windows Explorer or "My Computer" (or from Control Panel):
Go to Folder Options click the View tab and UN-check "Hide extensions for known file types", as shown in this Windows XP image from http://kb.mozillazine.org/Show_hidden_files_and_folders

After UN-checking "Hide extensions for known file types" in Folder Options, as shown above, can you now at least see the file extension after the file name in the Save Image window (e.g., filename.gif or filename.jpg) ?

Assuming you still see a blank "Save as type" box in the Save Image window, is the problem only happening in Firefox or does it also happen in Internet Explorer?

You also said, I don't wish to reassign jpg or any other extension to open with Windows Photo Viewer as default. That's the default on Windows 7. On Windows XP, the default is "Windows Picture and Fax Viewer". Since you can still save images, even though the "Save as type" box is blank, what program opens when you save a JPG image file and double-click it? What about a PNG file or a GIF?

You could try this utility to restore the default image file associations in Windows XP (which I found linked from this webpage)

Another solution I've seen mentioned on MozillaZine's forum for a blank "Save as Type" box with no options in the drop-down menu is to add those filetypes to another program's filetypes. QuickTime was mentioned here: http://forums.mozillazine.org/viewtopic.php?p=10984733#p10984733 ... but you could also try IrfanView from http://www.irfanview.com/ ... which is a program I have installed, and set it to handle PNG, JPG and GIF files.

Helpful Reply

Thanks for your detailed reply.

My Windows folder options are already set to display the extensions on filenames, and this facility works when I am viewing files in File Explorer and My Computer. I don't believe it has any impact on whether or not extensions are displayed in 'Save' dialog boxes offered by other software products.

All the picture software I use regularly (Photofiltre, Paint.NET, Irfanview, Microsoft Paint) displays its own selection of image types in 'Save as' dialog boxes. As far as I know the 'Save as' function in Firefox does not use any of these products.

The fault I have described in Firefox does not happen in Internet Explorer. The corresponding 'Save as' function in IE8 normally displays two image types - one is the format determined by the image being saved, and the other is always BMP. If the image is BMP to start with, then only BMP is offered.

When I double click a JPG, GIF, PNG or BMP image, it opens with Photofiltre. That is what I set as default for all image types I use regularly. Program-specific extensions such as PDN for Paint.NET open with the appropriate programs.

I am convinced this problem lies in Firefox itself. After further experimentation, I have concluded that the only way of resolving this problem is to use version 3.6.23 or earlier. Version 4.0.1 and all later versions exhibit the fault.

Modified by Rackbrane

André 0 solutions 2 answers

i have exactly same problem :(

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Does it work if you add the file extension yourself to each file that you save?

You can also try to add quotes around the name ("image.jpg") to see if that works if Windows is stubborn.

André 0 solutions 2 answers

yes, but the image type field continues blank

Wyndham 0 solutions 1 answers

I am surprised and disappointed at the lack of (apparent) response from Firefox developers to a problem which has been around for a long time.

It really isn't good enough that we have to fiddle around with various settings to try and fix this. I don't believe there is anything wrong with the settings on my PC. Having said that I have tried some of the suggestions offerred without improvement.

I do not have this problem with either Internet Explorer, Opera or Google Chrome... This problem is unique to Firefox"

The screenshot illustrates what everyone has been saying.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Yes, the problem is clear and reported previously - see the image posted here: http://forums.mozillazine.org/viewtopic.php?f=38&t=589354

If you have a plugin such as QuickTime installed that can handle image files, you could either disable the plugin (see Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems) or else try the solution posted 04 Jul 2011 to the above thread (on page 2):

1. Open Quicktime Player from your Start Menu.
2. Go to Edit>Preferences>Quicktime Preferences.
3. Go to Browser>MIME Settings.
4. Find .jpe, .jpeg, .jpg and .jp2. Check them all. Then hit Save.
5. ???
6. Enjoy.

You could also try to reset your file associations for image files to the default settings in Windows (Windows Picture and Fax Viewer in Windows XP, Windows Photo Viewer on Windows 7 - see above) and then test again. Afterwards, you can reset associations to your preferred programs.

Modified by AliceWyman

Tomasi 0 solutions 2 answers

I have encountered this problem many times since making Firefox my default browser and it seems to occur randomly and across any version of Firefox. Each time in the past I was able to somehow fix the problem but the solution never seemed to fit a pattern or even be the same from one time to another. One time I may have to simply uninstall and then reinstall Firefox - other times I had to boot first to safe mode before anything would work right. There seemed to be no rhyme or reason either to why the problem occurred or what version of hocus-pocus I had to employ in order to get things back to normal. What made things even more annoying was the fact that everything worked normally in whatever version of IE would load. Recently I installed Firefox 12 and - true to form - about a week or so later the mysterious problem reared its ugly head. This time, no matter what I tried, I was unable to repair the locked "Save as Type" dropdown menu. I was just about ready to dropkick my monitor into my neighbor's yard when I "accidentally" stumbled onto the fix for my situation. I am posting the solution I found below but with the disclaimer that it works only if you are using Microsoft Office Picture Manager as your image viewer. Here's what worked for me:

The Fix:

1.) In the Programs Menu - Select Microsoft Office

2.) Under Microsoft Office - Select Microsoft Office Tools

3.) Under Microsoft Office Tools - Select Microsoft Picture Manager

4.) Under Microsoft Picture Manager - Select Tools

5.) Under the Tools Menu - Select File Types

6.) When the File Types Menu Opens - Check Mark the Image Files You Wish to Have Opened by Microsoft Office Picture Manager

7.) Select "OK" and the "Save as Type" Dropdown Menu Should Once Again Work Normally

Hope This Helps

Tom

Tomasi 0 solutions 2 answers

I have encountered this problem many times since making Firefox my default browser and it seems to occur randomly and across any version of Firefox. Each time in the past I was able to somehow fix the problem but the solution never seemed to fit a pattern or even be the same from one time to another. One time I may have to simply uninstall and then reinstall Firefox - other times I had to boot first to safe mode before anything would work right. There seemed to be no rhyme or reason either to why the problem occurred or what version of hocus-pocus I had to employ in order to get things back to normal. What made things even more annoying was the fact that everything worked normally in whatever version of IE would load. Recently I installed Firefox 12 and - true to form - about a week or so later the mysterious problem reared its ugly head. This time, no matter what I tried, I was unable to repair the locked "Save as Type" dropdown menu. I was just about ready to dropkick my monitor into my neighbor's yard when I "accidentally" stumbled onto the fix for my situation. I am posting the solution I found below but with the disclaimer that it works only if you are using Microsoft Office Picture Manager as your image viewer. Here's what worked for me:

The Fix:

1.) In the Programs Menu - Select Microsoft Office 2.) Under Microsoft Office - Select Microsoft Office Tools 3.) Under Microsoft Office Tools - Select Microsoft Picture Manager 4.) Under Microsoft Picture Manager - Select Tools 5.) Under the Tools Menu - Select File Types 6.) When the File Types Menu Opens - Check Mark the Image Files You Wish to Have Opened by Microsoft Office Picture Manager 7.) Select "OK" and the "Save as Type" Dropdown Menu Should Once Again Work Normally

Hope This Helps

Tom