X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why am I getting chinese-looking text on my web pages?

Posted

Some web pages I open up have chinese-looking text in places. It seems to be where advertisements might be (after looking at the page through Safari) but sometimes it is the whole page.

Chosen solution

You're welcome

Could you please click the "Solved it" button to mark the thread as solved?

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

Months ago

Installed Plug-ins

  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r181

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Couldn't find anything in Help Troubleshooting

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can do a check for corrupted fonts and other font issues:

Question owner

Hi, I have a Mac Mini running Mac OSX version 10.5.8 and have this problem when I'm running Firefox version 4.0.1. Safari doesn't seem to have the problem. Some of my web pages show these chinese-looking characters, not like any of the samples shown in the link in your reply. I am attaching an image of a page from the KMart online shopping site, hopefully this will help you. Thanks

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

Looks that you are on UTF-16 encoding.
Switch to View > Character Encoding > Western (ISO-8859-1)

You can check the default encoding in:

  • Firefox > Preferences > Content : Fonts & Colors > Advanced

Modified by cor-el

Question owner

Hell0 again. Thank you so much for your reply. You are quite right about my encoding settings. I have gone in and changed both, first in View and then in Firefox Preferences but still have the same problem. Do I need to shut down and start again or anything for the settings to change? (sorry, not really very savvy with all this stuff). Thanks again.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

Does that page display correctly if you set the encoding to ISO-8859-1 ?

Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Question owner

Yes! Woohoo that worked! Now, will that stay in place for all the web pages or will I just have to wait and see?

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Hopefully it will stay, but in case that it happens again then check the encoding and reload the page and bypass the cache.

Question owner

Thank you very much. Maybe catch you again if I have another problem later. Megarren

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Chosen Solution

You're welcome

Could you please click the "Solved it" button to mark the thread as solved?

Question owner

I'm sorry, I'm getting the chinese-looking text on my Webjet flights page now. I've checked the encoding is all still on Western (ISO-8859-1) and reloaded the page using Cmnd+Shift+R and it didn't make any difference. (This page didn't do this before.) What do you think?

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Is View > Character Encoding also showing Western (ISO-8859-1), because that determines what you see?

Question owner

OK, when I opened up Webjet last night, saw the problem and sent you the message I had checked View and thought it was still on Western (ISO 5889-1). But when I checked it again just now after reading your message it was back on UTF. I have changed it back to ISO 5889-1 and all is well again! Thank you again. Megarren

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You're welcome.

Quite strange that Firefox chooses the wrong encoding.

Is the server sending an encoding via the response headers or via meta tag in the file or is Firefox guessing wrong?

Question owner

Hello, sorry took so long to reply but I don't know enough to answer the last questions. I have, however, just checked a couple of likely suspect web pages but I don't have any problems tonight - even though my View has chosen to be back on UTF-8. Would it make any difference that I have increased my internet allowance, (it had reached capacity and was running slow now)?

Question owner

PS Internet running nice and fast again now