X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable Plugin Check?

Posted

How do I disable this new "feature?"

  • It opens up a new tab on startup that I don't want.
  • The check doesn't even work half the time.
  • Most of the plugins it finds are "unknown" (despite the fact that I know where every one of them came from!)
  • It doesn't register that I've already updated all the plugins that it can find
  • And in case anybody from this plugin check project is reading this, please, please add in a way to stop this check from running on startup. I know you want to help, but you're just annoying the userbase.

Additional System Details

Sites Affected

https://www.mozilla.com/en-US/plugincheck/

Installed Plug-ins

  • npmnqmp 989898989877
  • getplusplusadobe162103
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • MetaStream 3 Plugin r4
  • PLATINUM technology, inc. Plug-in for viewing 3D worlds authored in VRML
  • 6.0.11.3006
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • npdivxplayerplugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • iTunes Detector Plug-in
  • DivX Web Player version 2.0.3.4
  • DivX® Content Upload Plugin
  • DivX VOD Helper Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60310.0
  • Office Live Update v1.5
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Rhapsody Player Engine Plugin
  • Google Update
  • Version 0.8.6f, copyright 1996-2007 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

tps5352 0 solutions 7 answers

I had no luck with other alleged solutions, and one I tried caused Adobe Flash Player to screw up (as others have reported elsewhere). Here’s what I did to help alleviate (not solve) the Plugin Check problem:

1. Type “about:config” (without quotes) in your web address box and hit return. This should take you to a (not-so-secret) Firefox configuration page that lists the many Firefox settings.

2. If you first get a warning message, click the "I'll be careful, I promise!" button. Do be careful not to mess up any settings unintentionally. (The worst scenario might be that you have to re-install Firefox—do you have your preferred Firefox version [e.g., 3.6] setup file saved somewhere? You may want to download it first, to be safe.)

3. Once on the about:config page, in the “Filter” box at the top type “plugins.update” (again, no quotes). This should reduce the visible list down to only two (or so) settings. (Don’t worry--doing this does not change or remove anything, just makes the list you see more manageable. The full list will still be there if you remove the filter.)

4. Double-click on the “plugins.update.url” setting line to change the address “https://www.mozilla.com/%LOCALE%/plugincheck/” to anything else you want, for example “http://www.google.com”, or “http://my.ebay.com”, or your homepage address. Then exit Firefox (there is no "save" action needed).

Now when you start Firefox again you will have two tabs, one with your homepage and one with that other address in place of the Plugin Check page. This doesn’t solve the problem, but at least you do not have to look at the annoying Plugins Check page. (You can always put the original address back in the about:config page if you do want to see the Plugin Check page.) If you make the address your homepage, you’ll have two homepage tabs and can ignore or delete the second one.

Let’s hope a real solution (for FF 3.6 users) is found soon. I suspect that Mozilla wants everyone to switch to Firefox 4, which may be the real answer. Annoying.

kjpjr 0 solutions 4 answers

I run FF 4 and am having the same problems with no solutions, I have tried the ones here.

Khaidee 0 solutions 1 answers

I was having the same problem Master Thief. I followed steps one through three that tps5352 listed above. I found the setting line "plugins.update.notifyUser" and clicked it to set the value to false. I then restarted my browser, and the second "Plugin Check" tab did not open. I tested the theory again by setting the value to true- the tab opened again. Set it back to false, no tab.

Hope this helps.

tps5352 0 solutions 7 answers

Khaidee, thanks but that doesn't work for me. The default setting for that line (on my PC) is "false." Changing back and forth from "false" to "true" and back makes no difference. The Plugin Check page still comes up. In fact, when I change it to "true" and exit Firefox (FF), upon restarting FF the value is back to being false!!?? What does THAT mean?

BTW, blocking the Plugin Check page address (using my Linksys router software) does not really help. Yes it's blocked. But FF still attempts to create a second tab and the page just gets hung up. Still annoying.

The only thing that partially helps for me is to put a new address (e.g., my homepage) in the “plugins.update.url” line in the FF configuration page "about:config" (as outlined in my post above).

Laszlo_500 0 solutions 1 answers

It reminds me of porn sites. Each hit is money in the till. It doesn't matter if it is true or false. Ticked off going back to IE.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can correct this issue by forcing the file blocklist.xml to update or wait until Firefox updates the file.
That update will remove the severity="0" flags in the file that cause the problem.

See:

  • Bug 663722 - The blocklist output is including severity="0" where it shouldn't be