X
Tap here to go to the mobile version of the site.

Support Forum

Why is the new Firefox upgrade incompatible with my Mac now??

Posted

I love using Firefox, it's by far my favorite browser. But when I opened it this morning, it says I am no longer protected because of the older version I'm using. I want to download the new version but it says that it is incompatible with my computer.  ?? This is the same operating system I've used and it's on the list of compatible OS....mac 10.5.

HELP please! I miss it already!

I love using Firefox, it's by far my favorite browser. But when I opened it this morning, it says I am no longer protected because of the older version I'm using. I want to download the new version but it says that it is incompatible with my computer. ?? This is the same operating system I've used and it's on the list of compatible OS....mac 10.5. HELP please! I miss it already!

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • http://www.facebook.com/fbplugin/
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Macromedia Shockwave for Director Netscape plug-in, version 10.1.1

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.17) Gecko/20110121 Firefox/3.5.17

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157977 answers

Firefox 4 requires at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 4 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here:

Firefox 4 requires at least OS X 10.5 and an Intel Mac. * http://www.mozilla.com/firefox/4.0/system-requirements/ For an unofficial Firefox 4 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at: * http://www.floodgap.com/software/tenfourfox/ Firefox 3.6.x (Mac OS X 10.4 and later) can be found here: * http://www.mozilla.com/en-US/firefox/all-older.html

Question owner

Thank you! I'll go with TenFourFox and hope Firefox comes to its senses.

Thank you! I'll go with TenFourFox and hope Firefox comes to its senses.
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157977 answers

You're welcome

You're welcome