Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop the check plug in page from popping up every time I double click the firefox desktop icon?

  • 19 replies
  • 47 have this problem
  • 872 views
  • Last reply by thrashard76

more options

Two pages pop up when I double click the firefox icon on the desktop, the home page and the check plug in page. How do I stop the check plug in page from repeatedly popping up when I double click the firefox icon?

Chosen solution

You can fix this problem with forcing the file blocklist.xml to update.

See:

Read this answer in context 👍 0

All Replies (19)

more options

Firefox can store multiple home pages, it is possible that the plugin check page has been set as a home page. Try resetting the home page to the site that you want as shown here - https://support.mozilla.com/kb/How+to+set+the+home+page

more options

Thanks for the reply. Unfortunately, resetting the home page to my yahoo page didn't fix the issue. The same check plug ins page still comes up with the original home page.

more options

Modified by mikeclark

more options

Type about:config in the URL bar and hit Enter.
If you see the warning, you can confirm that you want to access that page.

Pref = plugins.update.notifyUser if it shows as True, double-click that pref to toggle it to False

If that pref was already set to False, try disabling the QuickTime Plugin and then restart Firefox, to see if that is the culprit.

Modified by the-edmeister

more options

I checked the plugins.update.notifyUser and it was already set to false. I disabled Quick time and that had no affect to the issue either. Thanks for the response however. Hopefully there will be a fix for this soon.

more options

I uninstalled Viewpoint Media Player (and the AOL IM client "AIM", since apparently that's what forced Viewpoint Media Player on to my system.)

Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled.

For me, after uninstalling Viewpoint Media Player, the "plugincheck always opening" problem then went away.

more options

I uninstalled AOL IM and disabled MetaStream 3 Plugin but that didn't work either. I don't currently have viewpoint media player that I'm aware of.

more options

Thrashard76, when you get the "plug-ins check page," I presume it is a tab opening on the Firefox site, NOT the popup listing plug-ins, extensions, etc.?

If so, what plug-ins come up with an "Update" button active? They might help us determine what is causing Firefox to load the page.

more options

Yes, it is an additional tap page. A note: Adobe doesn't seem to update even after doing so. Also, from the Google Update plugin down, they are all unknown plugins and have "research" buttons for them. I haven't tried to research them as they didn't need to be updated like the above ones did.

Potentially vulnerable plugins:

Adobe Acrobat Adobe PDF Plug-In For Firefox and Netscape 10.0.1 Outdated Version

Silverlight Plug-In 4.0.60310.0 4.0.60310.0 Up to Date

Java(TM) Platform SE 6 U26 Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers 1.6.0.26 Up to Date

Shockwave Flash Shockwave Flash 10.3 r181 10.3.181.22 Up to Date

QuickTime Plug-in 7.6.9 The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site. 7.6.9.0 Up to Date

Java Deployment Toolkit 6.0.260.3 NPRuntime Script Plug-in Library for Java(TM) Deploy 1.6.0.26 Up to Date

Microsoft® Windows Media Player Firefox Plugin np-mswmp 1.0.0.8 Up to Date

Google Update Google Update Unknown plugin Research

Windows Presentation Foundation Windows Presentation Foundation (WPF) plug-in for Mozilla browsers Unknown plugin Research

Windows Live™ Photo Gallery NPWLPG Unknown plugin Research

GameTap GameTap Browser Helper Tool Unknown plugin Research

iTunes Application Detector iTunes Detector Plug-in Unknown plugin Research

Unity Player Unity Player 2.6.1f3 Unknown plugin Research

Facebook Plugin Provides additional functionality on Facebook. See our web site for details. Unknown plugin Research

downloadUpdater2 npdnupdater2 Unknown plugin Research

downloadUpdater npdnu Unknown plugin Research

RealJukebox NS Plugin RealJukebox Netscape Plugin Unknown plugin Research

RealPlayer Version Plugin 6.0.12.46 Unknown plugin Research

MetaStream 3 Plugin MetaStream 3 Plugin r4 Unknown plugin Research

2007 Microsoft Office system Office Plugin for Netscape Navigator Unknown plugin

more options

Here is a picture of the first few plugins on the tab. Thanks again for the responses.

more options

I uninstalled AOL IM and disabled MetaStream 3 Plugin but that didn't work either. I don't currently have viewpoint media player that I'm aware of.

MetaStream 3 Plugin MetaStream 3 Plugin r4 Unknown plugin Research

This is apparently the Viewpoint Media Player plugin npViewpoint.dll. Even though you don't see the Viewpoint Media Player listed in your list of installed programs, it might be listed as a different application.

Disabling the MetaStream 3 Plugin in the Firefox Add-ons Manager removes it from the about:plugins list but apparently does not stop the PluginCheck from finding it. You should re-enable the MetaStream 3 Plugin in the Firefox Add-ons Manager list of plugins. You can then find and remove the plugin file npViewpoint.dll from your computer, using the following instructions, from this thread at mozillazine:
http://forums.mozillazine.org/viewtopic.php?f=38&t=2224319 Plugin check is happening with each start up


Winston_Smith wrote:<snip>

The Plugin Check page listed about eight plugins with status listed as "unknown plugin." It turns out that the very last one on the list, 'MetaStream 3 Plugin', which dated all the way back to 1/13/2004, was the one triggering this "Update" Nag. Here's what I did.

  1. Enter about:config into the address bar
  2. Locate the preference 'plugin.expose_full_path' by typing it into the filter bar
  3. Toggle that preference true (right click, toggle)
  4. Enter about:plugins in the address bar
  5. The resulting "Installed Plugins" list will now show the full path and file name of the associated plugin DLL file.
  6. Simply go to the directory of the suspect plugin (using Windows Explorer or whatever) and rename the DLL file (I just appended '.OLD' to the DLL file name, e.g., 'npViewpoint.dll.OLD')
  7. Quit firefox (file, exit) and restart.
  8. If you don't get redirected to the Plugin Check page then problem solved. If you do get redirected to the Plugin Check page then the plugin you just nuked (by renaming the DLL file) should be gone from the list.
  9. Repeat with the other "unknown plugins" until you don't get redirected upon Firefox startup.

Modified by AliceWyman

more options

I don't have npViewpoint.dll on my computer and I have 13 unknowns in the plugin check list. I don't know which is the bad plugin and I don't want to corrupt a plugin if it isn't the bad one. Any ideas?

more options
more options

Here's what I did (the same as what Im_bonafide did):

[quote]I did follow the steps, Open URL about:config, write: plugins.update, then I set: plugins.update.notifyUser = false. Except it was already User = false. So, I set it to User = true. When I reopened the browser it magically changed back to User = false. However, I continued to get that annoyance.

I went back into about:config > plugins.update > only this time on the line below plugins.update.notify, I (R) clicked plugins.update.url > modify > & deleted the url: https://www.mozilla.com/%LOCALE%/plugincheck/and replaced with my normal home page url. /quote

https://support.mozilla.com/en-US/questions/832793#question-reply


This did the trick as far as stopping the check plug in page from popping up. However, I still get a second blank tab (due to erasing the https://www.mozilla.com/%LOCALE%/plugincheck/ link and leaving it blank instead). Hopefully a patch will be made soon that will altogether stop the second tab from opening. Thanks for the help, much appreciated.

more options

Chosen Solution

You can fix this problem with forcing the file blocklist.xml to update.

See:

more options

Thanks a lot for that tip. That fix you sent me (blocklist.xml) worked. I backed out of mozilla several times and that second tab never came up again. Again, thank you.

more options

You're welcome

more options

Now that the problem is solved, you should go back to about:config then right-click the plugins.update.url preference and select "Reset" so that the URL is reset to the default value.

more options

Ok, will do. Thanks again.