Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Just upgraded to (downloaded) 4.0.1but note pops up saying my version (old version) is not protected against online attacks - new version not showing up when Firefox opened

more options

When I opened Firefox this morning a note popped up saying my version needs to be upgraded to 4.0.1. I downloaded this version but every time I open Firefox the note still pops up. Version 4.0.1 did download. Why is it not opening with that version?

Chosen solution

Your user agent string (identifies the browser version) is reporting that you have Firefox 3.5.4 and not 4.0.1

A quick check to confirm what version you have, if the bookmarks menu has an item called "Organize bookmarks" you will be using Firefox 3.5.19, if it has an item called "Show All Bookmarks" you will have Firefox 4

If you have Firefox 4, you need to reset your user agent string so that it correctly identifies the version of Firefox.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click on it and select Reset, this will set the user agent string back to the default in Firefox 4

There are other user agent string settings that may have been modified, but these are no longer used in Firefox 4. You can reset them if you want, for details see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser


If you are still using 3.5.4, you will need to run the setup file for Firefox 4.0.1 that you downloaded in order to install it.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Your user agent string (identifies the browser version) is reporting that you have Firefox 3.5.4 and not 4.0.1

A quick check to confirm what version you have, if the bookmarks menu has an item called "Organize bookmarks" you will be using Firefox 3.5.19, if it has an item called "Show All Bookmarks" you will have Firefox 4

If you have Firefox 4, you need to reset your user agent string so that it correctly identifies the version of Firefox.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click on it and select Reset, this will set the user agent string back to the default in Firefox 4

There are other user agent string settings that may have been modified, but these are no longer used in Firefox 4. You can reset them if you want, for details see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser


If you are still using 3.5.4, you will need to run the setup file for Firefox 4.0.1 that you downloaded in order to install it.

more options

Tony:

Thank you SO much for your help. You gave me the easiest to understand instructions I have EVER gotten from anyone regarding computer problems. All I had to do was run the program - just like you said. Had no idea! (Guess that shows how computer illiterate I am.)

Thanks again!

Susan