X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable the "Plug-In Check" window from popping up everytime I open my firefox browser? It is totally annoying...thanks

Posted

Every time I open firefox browser a very ANNOYING "Plugin Check Window" pops up. My plugins are up to date. I don't want this reminder....PLEASE let me know how to disable it...thanks

Chosen solution

In the address bar, type about:config

Click the "I'll be careful, I promise!" button if it appears.

Type "plugin" into the filter box.

Find the entry plugin.scan.plid.all and set it to false.

You're done!

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Mozilla ActiveX control and plugin module
  • np-mswmp
  • MetaStream 3 Plugin r4
  • 1.7.0069.3
  • npsnapfish
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Motive Plugin for Mozilla Browsers
  • Google Updater pluginhttp://pack.google.com/

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET CLR 3.5.30729)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

You can correct this issue by forcing the file blocklist.xml to update or wait until Firefox updates the file.
That update will remove the severity="0" flags in the file that cause the problem.

See:


  • Bug 663722 - The blocklist output is including severity="0" where it shouldn't be
tps5352 0 solutions 7 answers

The extra Plugin Check page (or my homepage substitute) stopped appearing at Firefox startup on my PC a day and a half ago. (I waited to see if this problem would remain "fixed" before reporting) I did not do anything to cause the change (all previous efforts had been fruitless)--e.g., all the "about:config" plugin settings are default (except the address for "plugins.update.url." I still have an old Quicktime plugin version. (I did update Flash and Java plugins, but that did not stop the Plugin Check page from appearing.)

Instead of anything I did, I assume Mozilla changed something? If so, thank you. I hope it is fixed on your PCs also.