X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

You have conficting info about the new Firefox; the info and system requirements are for version 3.5.19 but the download is for 4.01. Will version 4.01 work on a mac PPC running OSX 4.11?

Posted

Question You have conficting info about the new Firefox; the info and system requirements are for version 3.5.19 but the download is for 4.01. Will version 4.01 work on a mac PPC running OSX 4.11?

Additional System Details

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Gecko default plugin
  • The iLok Client Helper Plug-in v3.4 allows you to use iLok.com to manage your iLok hardware keys. For more information, visit the iLok.com Web site.
  • Shockwave Flash 10.1 r53
  • The iLok Client Helper Plug-in allows you to use iLok.com to manage your iLok hardware keys.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides support for Digital Rights Management
  • Provides support for Windows Media.
  • Macromedia Shockwave for Director Netscape plug-in, version 10.1.1
  • Java 1.3.1 Plug-in
  • Java 1.3.1 Plug-in (CFM)

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.15) Gecko/20101026 Firefox/3.5.15

More Information

jscher2000
  • Top 10 Contributor
2368 solutions 20957 answers

Sorry, that is confusing. Firefox 4 is for Intel-based Macs only.

You should be able to run 3.6.17 on a PPC Mac.

Info: http://www.mozilla.com/en-US/firefox/3.6.13/system-requirements/

Download: http://www.mozilla.com/firefox/all-older