X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How did Superfish get on my PC? How do I remove it? It is causing crashes.

Posted

I think some that suggest superfish or surf canyon do not install anything unless you agree is complete nonsense. I think the work for these scam sites and trying to pull your leg. I searched all of my computer and did not find either one of them anywhere. I never allowed any software to install unless I have researched what or who they are and what good they do for me. But nevertheless I got this vicious software interfering with my search on every shopping site I was on. God knows what information they got. Imagine they are on the sites where you buy stuff and enter you passwords, credit card numbers, your address and phone numbers etc. Scary uh!!!. If this company is legitimate why dont they show up in you programs as superfish since their address is superfish.com? Why is there no easy way to uninstall this like real programs? Sorry but I think these scams need to be stopped and rooted out. Superfish: If you are legitimate show up on our computer as one! Dont sneakup and install your scamware in our computers. Please post removal instructions!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60129.0
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

There are several add-ons that include superfish, reports in these forums indicate that add-on that include it include IE Tab Plus, WindowShopper, FoxLingo, Convertor and Page tweaks. There will be others.

To identify which of your add-ons contains superfish you can disable all extensions, then re-enable them one at a time, restarting Firefox each time until you find the culprit. For more details on doing this see https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

You can uninstall the offending add-on - https://support.mozilla.com/kb/Uninstalling+add-ons

ryanhendricks 1 solutions 2 answers

if you are using fastestfox add-on, go to tools -> fastestfox -> search results tab -> uncheck add similar product search.

This worked for me and hopefully it will for others.

Ladd 0 solutions 1 answers

I have found Superfish/Windows Shopper associated with two Firefox add-ons so far.

Fasterfox 4.6.4 and converter-1.1.1

both extensions have superfish as an option. clear check box Enable Superfish price comparisons. Superfish all gone...

It appears that neither of these has superfish enabled as default, so I must have done it myself.

Superfish can be successively blocked with either Adblock Plus or NoScript add-ons if superfish has managed to piggyback in on something else that has yet to be discovered.

Walla2 0 solutions 1 answers

I have Firefox 11.0 and for me Superfish was bundled with the Calculator add-on. I disabled the Calculator, and Superfish went away.

Bratin 2 solutions 53 answers

Here's what you should do:

  1. Go to control panel
  2. After that go to performance and Maintenance
  3. Select System
  4. Select the System Restore tab
  5. Select Drive C
  6. Click ok
  7. A window should pop up
  8. Select a date that was BEFORE you downloaded Superfish
  9. It should do it's magic, and then your computer should be all good
niko62fr 0 solutions 1 answers

On my computer superfish was included in the Converter 1.1.1 add-on You can deactivate superfish in Converter : go to the add on management page and in front of Converter choose option, you can deactivate superfish in the "conversions" tab, just deselect "enable superfish price comparison"

sergcont 0 solutions 1 answers

I have Firefox 13.0 on Ubuntu 11.10

Also the Add On [Awesome screenshot] include it  :(

So I just keep it disabled and only enable it when capturing a screen !

hope this helps

Modified by sergcont