Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I upgraded to Firefox 4 - and when i started it said "Cant be used with this version of Mac OS". Cant find the older version - and why cant the application check for OS before installation >?

  • 2 replies
  • 39 have this problem
  • 1 view
  • Last reply by mmerlinn

more options

As usual - when i started up firefox on my Mac - it gave an indication of a later version available - but with no info on the Mac OS.. it downloaded and installed on mac os x 10.4.11 - and when i started up firefox - it said "cant open with this os".. now, i've lost my older version, and the new version wouldnt work either.. why couldnt the app check the OS before installation ? how do i get back to the earlier version ?

All Replies (2)

more options

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

more options

You cannot get any version prior to 3.6.19 at that link now. And I need 3.6.18 or earlier. Where do I get it?