Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I CANNOT GET RID OF a 'Just In Time Debugger' pop-up: " An exception 'Runtime Error' has occured in Script. However, no debuggers are registered that can debug this exception. Unable to JIT debug." Any advice would be great. Jaykay

  • 4 replies
  • 99 have this problem
  • 23565 views
  • Last reply by Jaykay

more options

Using Firefox 4 on XP 2000 Pro SP3 computer.

Chosen solution

See How to: "Enable/Disable Just-In-Time Debugging"

Read this answer in context 👍 2

All Replies (4)

more options

I think I solved it myself yesterday, indirectly by deleting a Googleupdater.exe file dated 042511. It has been over 24 hours now and no sign of the 'Just-In-Time Debugger' pop-up. Whew...it was incessant.

Not sure how I got the Googleupdater.exe file on my computer. I did download Microsoft Security Essentials to help find the JIT problem, but it failed to install properly and run. The next day I remembered it probably only runs on Internet Explorer (which we deleted in 2009) after testing out Firefox. I then also deleted Security Essentials.

I also downloaded on April 25th the free version of MS Visual Basics because I read on eHow that you can adjust settings in the 'TOOL' menu to stop JIT Debugging pop-ups. However, the free version was 'MS Visual Studio Basic 2008 Express Edition - SP1' which did NOT provide access to JIT Debugging settings (so it was not a solution).

I must say I switched Internet Security programs to AVAST! on TU | Apr26th and love it so far. Highly recommend looking into AVAST! ver 6.0 at CNET downloads - free. The anti-virus program is free, but everything else costs about $30US for a year. WORTH IT Love the options | settings | flexibility|user friendly windows.

Trend Micro was then deleted. It had always blocked usage of our internal CD|DVD drive. To use the CD|DVD drive we had to shut off Trend Micro and then turn it back on again after we finished using the CD|DVD drive. NOT a preference - for sure. Jaykay

Modified by Jaykay

more options

Chosen Solution

See How to: "Enable/Disable Just-In-Time Debugging"

more options

Thanks cor-el. I did delete the registry keys via a eHow article but I still got the JIT Debugger pop-up. Appreciate the links to the clear explanation about Visual Basic and how to enable or delete the JIT Debugging process. I saved them to a new bookmark folder. Jaykay

more options

For those who may read this going forward, after all best efforts to remove 'JIT Debugger' via the Registry find|delete process (Start\Run\Regedit\Find etc): I discovered another JIT Debugger location.

C:\Programs\Common Files\Microsoft\VS7Debug within were about 8 files including a 'MDM.exe' application Machine Debugger Manager with the options to display current JIT debugging settings and configure remote JIT options.

Another file is the JIT Debugging Handler and CLR Remote Host It has the option to attach a debugger to process id.

Just in case this helps someone.

As of this writing (actually 24 hours ago) the JIT pop-up has completely ceased (yaa!) Jaykay