Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I find out the RGB values of the PURPLE (private mode) Firefox Button?

  • 19 replies
  • 4 have this problem
  • 358 views
  • Last reply by cor-el

more options

Or HSL values?

Thanks

Chosen solution

Don't include the leading '*' characters from the code in a comment section.
Those were only added to reflect that you are in a comment section.

This code should work:

menupopup > * {
 font-size: 15pt !important
}
Read this answer in context 👍 0

All Replies (19)

more options

make a screenshot, paste it in Paint, use the color selector tool on one of the purple pixels, then go to the "change color" menu entry, there you'll have rbg as well as hsl values

more options

See:

  • chrome://browser/skin/browser.css

#main-window[privatebrowsingmode=temporary] #appmenu-button {
  background-image: -moz-linear-gradient(rgb(153,38,211), rgb(105,19,163) 95%);
  border-color: rgba(43,8,65,.9);
}
more options

Hi,

You’ve answered two of my questions. Thanks for your help. I really appreciate it.

Concerning the ‘App Menu Spy Icon’ style: I just installed it, and didn’t use any code of my own.

Regarding the RGB values of the Firefox Button: I use a png editor which doesn’t support RGBA. Is the .9 equivalent to 90% opacity? (I’ve tried those values, and got a darker purple.)

Thanks again, Yaron

more options

That dark border color may not be that noticeable:

data:text/html;charset=utf-8,<div style="background-image: -moz-linear-gradient(rgb(153, 38, 211), rgb(105, 19, 163) 95%); border: 2px solid rgba(43,8,65,.9);
color:white;text-align:center">Purple color gradient</div>

Modified by cor-el

more options

The 'moz-linear-gradient' is new to me.

I've tried to change the purple color to red by adding the following code to userChrome.css

[browsingmode=private] #appmenu-button {

 background-color: rgba(255,0,0,1) !important;

}

For some reason Firefox ignores it. (Why?)

After reading your precise explanation, I located the browser.css file. How do I edit that file so that the purple would be replaced by red (RGB (255,0,0))?

I guess I should refer to mouseover-state as well.

I really appreciate your help. Thank you.

more options

Thank you.

It helped me a lot.

more options

[browsingmode=private] is no longer supported.

You need to use this selector:

#main-window[privatebrowsingmode="permanent"] #appmenu-button
more options

Thanks.

Firefox still ignores userChrome.css.

more options

Make sure that windows hasn't added a hidden .txt file extension if the file isn't working

more options

I couldn't find any hidden .txt file in the chrome folder. What did you mean by 'hidden .txt file extension'?

Thanks for your time and help.

more options

Windows doesn't show certain file extension by default, So unless you have set to show all file extensions ("Hide extensions for known file types" is not checked) then you do not see a possible .txt file extension that Notepad adds automatically while saving a text file. You can verify that via the Properties (right-click context menu).

more options

I unchecked "Hide extensions for known file types", and there isn't a hidden .txt file.

Any other idea?

Thank you.

more options

Is other code that you place in that file working?

more options

I've tried:

menupopup > * {
*   font-size: 15pt !important
* }

It didn't work either.

Thanks.

more options

That doesn't look like valid code (check the Tools > Error Console).
Is there other code in userChrome.css that can cause this problem?

This should be visible:

#urlbar *, #FindToolbar *, #search-container * { font-size:13pt !important; }

You can try this extension:

Modified by cor-el

more options

Your code works.

This is my userChrome-example.css:

/*
 * Edit this file and copy it as userChrome.css into your
 * profile-directory/chrome/
 */

/*
 * This file can be 

used to customize the look of Mozilla's user interface
 * You should consider using !important on rules 

which you want to
 * override default settings.
 */

/*
 * Do not remove the @namespace line -- it's required for 

correct functioning
 */
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* 

set default namespace to XUL */


/*
 * Some possible accessibility enhancements:
 */
/*
 * Make all the default 

font sizes 20 pt:
 *
 * * {
 *   font-size: 20pt !important
 * }
 */
/*
 * Make menu items in particular 15 pt instead of 

the default size:
 *
 * menupopup > * {
 *   font-size: 15pt !important
 * }
 */
/*
 * Give the Location (URL) Bar a 

fixed-width font
 *
 * #urlbar {
 *    font-family: monospace !important;
 * }
 */

/*
 * For more examples see 

http://www.mozilla.org/unix/customizing.html
 */
 

I took the following code from there.

menupopup > * {
*   font-size: 15pt !important
* }

Why didn't this work?

Thank you so much.

Modified by cor-el

more options

Chosen Solution

Don't include the leading '*' characters from the code in a comment section.
Those were only added to reflect that you are in a comment section.

This code should work:

menupopup > * {
 font-size: 15pt !important
}
more options

It works.

I've learned a lot from you. I really appreciate it. Thank you.

more options

You're welcome.