Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When clicking on Google search results, Firefox goes to further engines with resultses!

  • 3 replies
  • 2 have this problem
  • 3 views
  • Last reply by Xircal

more options

When I enter a topic in the Google search bar, Google returns the list of results, when I click on the the result I have chosen, Firefox then takes me to another search engine's results, offering me further choices. It is SOOO annoying!

Firefox 4.0 also crashes 3 or 4 times a day EVERYDAY!

How can I role back to Firefox 3?

Chosen solution

It sounds like you have a browser hijacker installed which is redirecting your searches. Please do the following:


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=
  • Go to File | Exit
  • Restart Firefox, go to the site you want to set as your homepage.
  • Go to Tools | Options | General.
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

It sounds like you have a browser hijacker installed which is redirecting your searches. Please do the following:


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=
  • Go to File | Exit
  • Restart Firefox, go to the site you want to set as your homepage.
  • Go to Tools | Options | General.
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.

more options

Many thanks Xircal, it worked a treat and cleared the problem, the only disconcerting thing about it, is that it is McAfee Sercure Search via YAHOO that was the problem and was rerouting my searches all over the place to what ever matched they could find.

Thank you!

Ray

more options

You're welcome.

Modified by Xircal