X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Downloaded new FF4.0. Rebooted. Now have disabled yahoo toolbar. went to Ff site and tried to install suggested Yahoo toolbar but FF says I still have FF2.0.0.2. Please help. I need my yahoo TB back!

AJ
Posted

Upgrading to FF4.0, and manually rebooting again. Window opened and Yahoo toolbar was mostly gone, except for white search box and its search button. Both are currently disabled. All other buttons that were with my Yahoo TB are gone. Went to FF website using google search. Looked for Yahoo toolbar that worked with FF4. Followed the steps but FF continues to say: "You are currently using Firefox 2.0.0.20". This happened in two places. It is not recognizing that I have upgraded to FF4. How do i fix this?? Thanks so much!

Chosen solution

If a site reports that you have an earlier version after installing Firefox , you will need to change a hidden preference. This preference may have been added by an extension and will be causing your problem.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click on it and choose Reset
  4. Restart Firefox and it should correctly identify that you have Firefox 4
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • np-mswmp
  • Yahoo! activeX Plug-in Bridge
  • 1.9.0009.1
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Shockwave Flash 10.2 r153
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 (.NET CLR 3.5.30729)

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

If a site reports that you have an earlier version after installing Firefox , you will need to change a hidden preference. This preference may have been added by an extension and will be causing your problem.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click on it and choose Reset
  4. Restart Firefox and it should correctly identify that you have Firefox 4

Question owner

TonyE YOU ARE AWESOME! You solved it so fast! You gave me an easy solution! Thanks so much!

TonyE
  • Moderator
1041 solutions 8840 answers

You're welcome

betnj 0 solutions 4 answers

bold textI followed the instructions: 1.Type about:config into the location bar and press enter . 2.Accept the warning message that appears, you will be taken to a list of preferences . 3.Locate the preference general.useragent.override, right-click on it and choose

I could not find "general.useragent.override," in the directory.

The only listings under general.useragent. are general.useragent.compatMode.firefox, general.useragent.extra.asktb, general.useragent.extra.microsoftdotnet and general.useragent.locale.

There is no "general.useragent.override." I have FF 4.0 version.

TonyE
  • Moderator
1041 solutions 8840 answers

betnj, that preference is not included by default. Do websites report you have an earlier version?

You can right-click on all of the general.useragent.* preferences and choose Reset, some of those you listed will not be used by Firefox 4 and resetting them will remove them.

scribblers 0 solutions 4 answers

@ TonyE I upgraded to FF 4.0 recently and am unable to locate my Yahoo Toolbar application buttons. All that appears is the Yahoo search block. I've tried your suggestion but no luck. I'm operating with MS Vista.

betnj 0 solutions 4 answers

Thank you, Tony for the information. I do have Firefox 4.0. For some inexplicable reason, when I opened Firefox the next day, the Yahoo Toolbar was back. I read that they are coming out with Firefox 5.0 very soon and that Yahoo sometimes shuts down their Toolbar to tweak it or run it through Spy Bot. It would be nice if they could announce that somewhere on the My Yahoo home page or on Firefox somewhere; or maybe send an email to Yahoo ID members. Thanks again for your help.

scribblers 0 solutions 4 answers

Same here! Toolbar buttons miraculously reappeared today, although there were a few that needed to be reinstalled. Thanks to all that made this happen.

betnj 0 solutions 4 answers

You are very welcome. I did not have any problem with the toolbar. All my icons were there. I think from now on I'm not going to panic when the Yahoo Toolbar is missing but just wait a day or two until they put it back. Have a great day.