Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My OS X does not support 4.0, but I wasn't aware and downloaded anyway. Now I cannot open Firefox at all. How do I get back to 3.6 or another?

  • 1 reply
  • 4 have this problem
  • Last reply by cor-el

more options

I had Firefox 3.6.something (I'm not sure). When it said I needed to update to 4.0, I just clicked ok. Now I cannot open Firefox. I removed it and looked for an older version, but all I can find is 2.0 and still cannot find a version in between the two.

All Replies (1)

more options

Firefox 4 doesn't run on a PowerPC Mac. Firefox 4 requires at least OS X 10.5 and an Intel Mac.

For Mac OS X 10.4.11 or Mac OS X 10.5.8 you can look at:

Firefox 3.6.x can be found here: