X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I download firefox for Mac 10.4.11? I have tried to download 3.6 and it won't download.

Posted

My iMac uses powermac chip.

Chosen solution

Firefox 3.6 supports your PC, but Firefox 4.0 doesn't.

Download 3.6.16 here:
http://www.mozilla.com/en-US/firefox/all-older.html

For older Macs that aren't supported in Firefox 4.0, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/

Read this answer in context 37

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/4.1.3 Safari/533.19.4

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24405 answers

Chosen Solution

Firefox 3.6 supports your PC, but Firefox 4.0 doesn't.

Download 3.6.16 here:
http://www.mozilla.com/en-US/firefox/all-older.html

For older Macs that aren't supported in Firefox 4.0, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/

DoomLife 0 solutions 2 answers

Helpful Reply

I'm running Mac OS X 10.4.11 "Intel," TenFourFox doesn't help with that. Whenever I load Firefox it tells me to upgrade to 12.0 for security reasons. 12.0 is most definitely not compatible with the version of OS X on my MacBook Pro. Then when I try to register for the forums on this site to address these issue (which they recommend to do on here), I am told I can't sign up because I am running an old version of Firefox. Could that possibly be more annoying considering the reason I'm trying to register in the first place? Anyways, do you have any recommendations or does Forefox just not concern themselves with the affairs of people who can't afford to buy new computers?

DoomLife 0 solutions 2 answers

let me know whats up...

Modified by DoomLife

bertrandf 0 solutions 1 answers

Helpful Reply

I have the same complaint. Firefox automatically "upgraded" for me, without asking, and it doesn't run since I have macosX 10.4.11. This is super-annoying. I stayed with Tiger for multiple reasons, even tho this happens to be an intel machine, and that should be my choice whether to install Lion/Leopard or not. Plus I have an old Macbook ppc which won't run the recent os's. Now I am on Safari since my favorite browser, Firefox, has committed suicide or rather replaced itself by a useless copy which refuses to run with this OS. Are you geniuses to allow the thing to install where it is not welcome? Plus, if you try to submit a comment on the Firefox page, it says you have to do it FROM the firexox brower. Brilliant!!!

ideato
  • Top 25 Contributor
617 solutions 4263 answers

bertrandf FF update to 13 and now you can't open ? sorry about that.

1. Download (with your safari) a copy of 3.6.28 from

  http://www.mozilla.org/en-US/firefox/all-older

2. Trash the current Firefox application to do a clean install.

3. Install the version that you have downloaded (3.6.28).

Do not select to remove your personal data, your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks or other personal data.

see also: Installing Firefox on Mac


see if you like, in the-edmeister's reply TenFourFox for PowerPC's Mac


thank and sorry again

korpan44 0 solutions 1 answers

The link you have posted does not work. It say's Firefox 3.6 is out of date with no download option. I'm also running 10.4.11. This is very frustrating as I had a ton of bookmarks and everything on Firefox and that stuff doesn't transfer. Thanks for your support firefox.

Guessing 0 solutions 1 answers

I had same problem and none of the links above worked. I downloaded firefox 3.6.28 from

http://www.macupdate.com/app/mac/10700/firefox

hope this helps others