X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Back Button not working in FireFox 4

Posted

Is anyone else having trouble with the back and forward buttons not working in FireFox 4? I installed 4 on an XP desktop and a Vista 64 laptop, and the forward and back buttons don't work on either installation. Does anyone know a fix for this? I tried deleting the "places" files in the profile and that does not help.

Additional System Details

This happened

Every time Firefox opened

This started when...

I upgraded to FireFox 4

Installed Plug-ins

  • np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.2 r153
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Live Update v1.5
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

More Information

AlbertMees 0 solutions 2 answers

It is evident that FF4, FF5 and FF6 are screwed up concerning the browser back function, *if* a navigation is done via JavaScript and a frameset is involved. In many cases, the browser history gets lost, in other cases not. It apparently depends on which JavaScript is used. In *all other browsers* it works nicely, so the programming is not to blame.

This can be easily demonstrated by doing a simple navigation at a site like

Version1: http://www1.rgzm.de/samian/home/frames.htm ---> click on something like "books" and then try the back button. It won't work.

The browser back functionality works well when using a different JavaScript at

Version2: http://www1.rgzm.de/samian/home/frames2.htm

Both website versions worked in FF3.6 and all other browsers. Version 1 stopped functioning in FF4+

And there are many different JavaScript based navigations out there on the net...

So, to conclude, this sodding annoying bug in FF4+ will cause many people to switch to any of the other browsers, which don't stumble on JavaScript being used in a frameset based navigation. It is also amazing to see that JavaScript still causes Mozilla Firefox so much troubles in FF4-6, whereas this is with the other browsers not the case (anymore).

AlbertMees

lovingthesixties 0 solutions 3 answers

I just had today the same problem, but with FF 3.6.22. I tried all the suggestions that everybody had already posted here, but none of them helped at all. Finally I got Revo Uninstaller out and blasted all of the Firefox pieces to Kingdom Come. Of course, I cannot tell you which piece was causing the problem, but on reinstalling FF again for what seemed like the umpteenth time today, it now works. Oh, one minor detail that may or may not be significant: after having tried unsuccessfully to roll back to version 3.6.19 (I got error messages that seemed to accuse me of trying to mix parts from the two versions.), I installed v. 3.6.19 just to be safe, since I had used it for awhile with no problem whereas I started having problems with v. 3.6.22 almost as soon as it installed itself, which it now cannot do because I changed the update option under Tools. So I solved the specific problem with Revo, but I cannot point to any specific cause for it. I suppose I could have switched to v. 6.x, but I keep hearing stories that seem to be even worse than my problems with v. 3.6.22, bad as they were. I just hope 6.x (or 7?) is free of serious problems by the time security updates end for v. 3.6.x. And in case you're wondering, I don't know when or if I'll go back to v. 3.6.22, but I know I'll never ever want to go back to IE as my main browser. Amen.

HerbieDerbie 0 solutions 1 answers

SOLUTION:

The problem / culprit is TAB MIX Plus....especially if you're still using FF 3.6 like me. If you don't want to uninstall and reinstall TM Plus, then restore it from a backup copy made via FEBE addon, or restore from a previous hard drive backup.

The problem appears starting with TM Plus version 0.3.8.7pre**** version.

It also caused Back/Forward buttons not to work....FEBE addon problems, bookmarking problems, and more.

This was the only addon that was causing the problem....

Revert back to previous version of TAB Mix Plus!!!

HINT: go to a webpage, like google, and right click...the right click context menu is FULL OF TMix OPTIONS!......very long menu!

However, in my TM Plus configuration section....I only checked 4 menu options to show. This appears to be a broken version / error in the code somewhere.

Let us know if this works for you folks who try this.

Modified by HerbieDerbie

cytosine 0 solutions 1 answers

I've had exactly the same problem and I resoved it by disabling TelevisionFanatic in Firefox extention.

hendra.cuber 0 solutions 2 answers

I had the same problem, but i've solved it. Try to create new firefox Profile. On windows, press win + r to bring up the "run dialog", then type "firefox.exe -P" without quote, and create a new profile. This at least worked for me. NB: I don't have McAfee site advisor.