Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am having trouble with all websites that have the embedded Windows Media Player. If I go to a page with a Webcam that is using Windows Mwdia, the player does not play or even show up. Any ideas?

  • 3 replies
  • 43 have this problem
  • 166 views
  • Last reply by Marian_SK

more options

With all my other browsers, thia is not an issue including Firefox 3.6. For example, this page http://www.liveduvalstreet.com/ will display fine in every browser except Firefox 4. Because of that issue, I reverrted back to 3.6 until I can find a fix. I have tested this page in Chrome, Maxthon 2 and 3, Internet explorer 8 and Firefox 3.6 with no issues at all. This is just an example site. All sites with the embedded player will not work.

Chosen solution

First, make sure that you have the wmp plugin installed from here: http://port25.technet.com/pages/windows-media-player-firefox-plugin-download.aspx

I had the same problem, posted the question, but got no response. By disabling all add-ons & enabling one by one, I finally discovered that 'RealPlayer Browser Record Plugin' was "blocking" all embedded wmv plays. This extension was installed automatically when I installed FF4. And I don't have the option to uninstall it

Here's a easy test: http://webaim.org/techniques/captions/windows/media/embed.htm

With that Realplayer add-on enabled, the video won't play; with it disabled it will.

I wish some of these gurus here would post more detailed info about this. You and I can't be the only people with this problem. (Yes, I have the correct wmpfirefoxplugin(dot)exe installed correctly)

Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

First, make sure that you have the wmp plugin installed from here: http://port25.technet.com/pages/windows-media-player-firefox-plugin-download.aspx

I had the same problem, posted the question, but got no response. By disabling all add-ons & enabling one by one, I finally discovered that 'RealPlayer Browser Record Plugin' was "blocking" all embedded wmv plays. This extension was installed automatically when I installed FF4. And I don't have the option to uninstall it

Here's a easy test: http://webaim.org/techniques/captions/windows/media/embed.htm

With that Realplayer add-on enabled, the video won't play; with it disabled it will.

I wish some of these gurus here would post more detailed info about this. You and I can't be the only people with this problem. (Yes, I have the correct wmpfirefoxplugin(dot)exe installed correctly)

Modified by iowaman

more options

Thanks a million! Thatr did the trick. I had an older versiuon of the plug in installed as well.

more options

My operating system is Windows 7 (64-bit) and I solved this problem in this way:

- Close Firefox 4 at first.

1. Install plugin for Windows Media Player normally, from this link: http://port25.technet.com/pages/windows-media-player-firefox-plugin-download.aspx

2. After the installation is created a folder called Plugins in the installation´s directory of Firefox 4

3. Go to the installation´s directory of Firefox 4 and copy the folder Plugins into your profile folder. (The profile folder should contain then folders e.g.: Cache, Extensions ... and other. But one of the folder must be Plugins).

4. After this you can test, if is Windows Media Player plugin functional. By me was this operation successfull and embedded videos in the website can be played now.

(Subjectively: in my opinion has the plugin slower reactions, but videos are played without problems).