X
Tap here to go to the mobile version of the site.

Support Forum

I replaced my Firefox3.6 with version 4 which won't run on my computer. How can I reinstall Firefox 3.6?

Posted

I replaced Firefox 3.6 with version 4 which won't run on my computer. How can I reinstall Firefox 3.6?

I replaced Firefox 3.6 with version 4 which won't run on my computer. How can I reinstall Firefox 3.6?

Chosen solution

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

Read this answer in context 4

Additional System Details

This happened

Just once or twice

This started when...

Installed new version.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/4.1.3 Safari/533.19.4

More Information

TonyE
  • Moderator
1044 solutions 8863 answers

Chosen Solution

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html