Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have a MAC OS 10.4.11 and just downloaded Firefox 4 but am not able to open it - it says "you cannot use the application Firefox.app with this version of Mac OS X". Help!

  • 9 replies
  • 1122 have this problem
  • 375 views
  • Last reply by iz2sick

more options

i followed instructions and the download went fine. i dragged the icon to the dock but cannot open it either from the dock nor from the applications folder.

All Replies (9)

more options

OSX 10.4.x is not supported for Firefox 4 - here is the system requirements page: http://www.mozilla.com/en-US/firefox/system-requirements.html.

http://www.mozilla.com/en-US/firefox/all-older has the latest 3.6.x version, and http://www.floodgap.com/software/tenfourfox/ is another option.

more options

mozillamarcia, as annejanssen has an Inter Mac she will not be able to install the unofficial tenfourfox version, as that one only works on PPC Macs.

more options

The mozilla firefox homepage is misleading. It says the new 4 version is for "Mac OS X". They need to clarify it is for 10.5 and above ONLY. Those of us with 10.4 ARE OS X, so it makes us think that firefox 4 will work for us, only to download & install it & discover that it does not work for OS 10.4. Then we have to re-download 3.6. It's very annoying & a waste of time for us. Firefox needs to amend the wording ASAP.

more options

I totally agree, this has caused a lot of problems for those with older Macs. The system requirements should be clearly displayed.

more options

The download page is very misleading. It does not specify that you have to have 10.5 or higher. I am very disappointed and annoyed with Firefox right now.

more options

I also had this problem with Mac OS X 10.4. Can someone please explain to me how to downgrade and reload the 3.6 version?

more options

you can uninstall 4.0 by dragging the application to the trash bin and then reinstalling the 3.6 version which you can find here: http://www.mozilla.com/en-US/firefox/all-older.html (just choose your language).

all your settings will still be there!

I agree with previous posts that it should be made clear on the 4.0 download page that this is not for people with 10.5 and above only. Seems like a very small addition to the website that would save a lot of trouble.

more options

Thank you! Downloaded and functioning again : )

more options

It angers me greatly that many a software still support Windows XP, yet they do not support older Mac OS's like 10.4.11. For this very reason, I'm also frustrated with Apple as their iTunes did the same thing.

This is my wife's MacBook and I'm going to make sure her next laptop is a PC. Thanks for leaving your supporters with only 5 year old MacBooks out Mozilla. I expected this from Apple, MS, and Google, but not you.

I really don't know what everyday people see in Apple (I can understand why designers and some other professions prefer it). Forcing you to upgrade an OS that still works perfectly fine is a load of BS.

Modified by iz2sick