Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 is incompatible with OSX v10.4.11. I replaced the old Firefox and am left with nothing. What do I do?

more options

After updating to Firefox 4 and replacing 3.6, I am left without the ability to use this browser. I cannot find an older version to download either. There needs to be a fix or a link to download 3.6. I've already seen that there are many others encountering this exact issue.

Chosen solution

All Replies (2)

more options

Chosen Solution

You can download an old version here: http://www.mozilla.com/en-US/firefox/all-older.html

more options

Thanks, alenotte!