Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cant run the latest version of firefox on my mac OS, need to uninstall it

  • 9 replies
  • 169 have this problem
  • 186 views
  • Last reply by edge

more options

I downloaded the latest firefox so I could use the firefox app for my new Iphone. I only have Mac OS X 10.4.11 and the new firefox wont run on it. Now whenever I open firefox I just get told that I cant run it on my OS. I want my firefox back! All my bookmarks, my addblocker. Safari stinks! I don't know how to uninstall it if I can't even open it! help!

Chosen solution

You can move the Firefox installation map to the Trash:

  • Applications/Firefox.app

You can find all Firefox versions here:

Read this answer in context 👍 3

All Replies (9)

more options

Chosen Solution

You can move the Firefox installation map to the Trash:

  • Applications/Firefox.app

You can find all Firefox versions here:

more options

THANK YOU!!!!!

more options

You're welcome

more options

There is an independent group re-building Firefox 4 features (minus the parts that require 10.5+ You can get it here: http://www.floodgap.com/software/tenfourfox/

more options

I saw that, but I have an early 2007 Intel iMac running 10.4.11. Is there any individual or group that is developing a Firefox 4 version for Intel Macs running Tiger? There used to be someone who developed optimized builds called "Minefield," but I don't see anything current about those on his Web site.

more options

I went to the site cor-el suggested, I see no English (US) version except for 4. Am I just not seeing it?

more options

Think I just found it. You need to click on the right hand side where it says Firefox 3.6.16 (under the search.

It's confusing because on the left the are some Firefox 3.6.16 for other languages.

more options

Thanks cor-el this worked like a charm.

more options

The link you gave only has FF4, no earier versions. I already uninstalled FF4 and I want the earlier version or I'll have to find a different browser.