Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do I get rid of a coupon bar?


I get this yellow bar at the top of my screen asking if I want to see coupons. It is not a toolbar. To the best of my knowledge, it is not an add-on. (If it is, it has an obscure name.) I don't remember installing anything like this. It is not on the list of programs that I can delete. I want to be rid of this nuisance.

Additional System Details

This happened

Every time Firefox opened

This started when...

can't remember.

Installed Plug-ins

  • Image Control Plugin for viewing images on Ancestry.com. Version
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • Default Plug-in
  • Shockwave Flash 10.2 r152
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Update


  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20110303 Firefox/3.6.15 (.NET CLR 3.5.30729) SearchToolbar/1.2

More Information

  • Top 10 Contributor
  • Moderator
3196 solutions 24401 answers

Without seeing a screenshot of it we can only guess what the problem may be.
Use the Add images: - Browse... button under the Post a Reply box to select the screenshot image you want to upload to this forum/

You might want to disable or uninstall the SearchToolbar/1.2 extension that you have installed. It usually gets installed with other programs, not something a user normally installs them self/

mohmd.faisal 0 solutions 1 answers

Helpful Reply


I have same issue and you can get screen show by clicking the following link:


Thanks, Faisal

lrosenblatt 0 solutions 1 answers

Helpful Reply

Hi there,

I also had this problem. After digging around a little bit, with no luck on Google, I was able to solve the issue.

This yellow coupon bar is powered by 'Cloudfront.net'. So, here's how to block the host, so the coupon bar will no longer load no matter which browser you're using.

1. Go Start > All Programs > Accessories > Run (or if you have Windows Vista/7, the start menu search box will work also)

2. Type "C:\Windows\System32\Drivers\Etc\hosts" (without quotes) -- if prompted, open this file with Notepad.

3. At the very end of the list of hosts, make copy and paste this: d3lvr7yuk4uaui.cloudfront.net

NOTE: Cloudfront.net powers many applications on the Amazon AWS platform. In the event that blocking only "d3lvr7yuk4uaui.cloudfront.net" does not work, a last resort would be blocking the entire domain. (Most likely, you will not encounter any issues in doing so.) To block the entire domain, add this entry to the hosts file: cloudfront.net

4. Save the "hosts" file, clear all of your browser caches, and restart your computer.

The pesky coupon bar should no longer appear :-)

Modified by lrosenblatt