X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

save and quit option has disappeared so how do I get it back?

Posted

I downloaded the latest version of firefox and now the save and quit feature is gone. How do I get it back?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50524.0
  • Google Update
  • Version 0.8.6d, copyright 1996-2007 The VideoLAN Teamhttp://www.videolan.org/
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Helpful Reply

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 3 preferences browser.warnOnQuit, browser.warnOnRestart and browser.showQuitWarning

Question owner

Thanks for the reply but I didn't like version 4b anyway so I have uninstalled it... problem fixed

the "browser.showquitwarning" doesnt exist anymore.... why has it been removed? pleaase put it back, i really liked the feature whiched saved my tabs to come back to later!! :(

Raghav 0 solutions 4 answers

Here is a very simple solution for this issue...

you can set preferences in Options-->General-->Startup-->When Firefox starts:Show my windows and tabs from last time and then quit Firefox clicking exit in the Firefox button menu instead of using the close button at the upper right corner of the screen,that will cause Firefox to display all the the tabs from the last session.

Enjoy your browsing

Modified by Raghav

Raghav 0 solutions 4 answers

Here is a very simple solution for this issue...

you can set preferences in Options-->General-->Startup-->When Firefox starts:Show my windows and tabs from last time and then quit Firefox clicking exit in the Firefox button menu instead of using the close button at the upper right corner of the screen,that will cause Firefox to display all the the tabs from the last session.

Enjoy your browsing

Raghav 0 solutions 4 answers

Here is a very simple solution for this issue...

you can set preferences in Options-->General-->Startup-->When Firefox starts:Show my windows and tabs from last time and then quit Firefox clicking exit in the Firefox button menu instead of using the close button at the upper right corner of the screen,that will cause Firefox to display all the the tabs from the last session.

Enjoy your browsing

smo 45 solutions 498 answers

pls ignore

Modified by smo

dww-uk 0 solutions 1 answers

Helpful Reply

browser.tabs.warnOnClose is already set, but that only warns I have multiple tabs open, it no longer offers to save them. Setting Show my windows and tabs from last time isn't the answer either, because I only want to keep the tabs sometimes; usually I don't.

As this was standard behaviour in FF 3, and as most users won't go onto blank:config, the default behaviour ought to be to have a control which offers 3 options: Close Tabs, Save Tabs for next time and Cancel. Plus a check box (default SET) which can be cleared to exist immediately next time, (and can be set within the Options).

The FF 4 behaviour is very annoying - the ability to simply save all tabs for next time was one of my favourite features of Firefox.

Modified by dww-uk

dazweeja 0 solutions 1 answers

@dww-uk, the browser.showQuitWarning options restores the default behaviour of Firefox 3.

I think this is a very poor usability decision on behalf on Mozilla, especially for those coming from Firefox 3. To achieve the same effect in a more usable fashion, they could have shown the default Save/Save on Quit dialog with an extra checkbox (unchecked) saying, 'Make this my default action and don't ask me again'. Then users would have the choice of which behaviour they prefer.

BlossomingContradiction 0 solutions 2 answers

I would totally prefer this. Do you know how I can get the old version back? If I uninstall the new one, I'm not sure where to retrieve the old...Thanks for your patience.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

Are you guys aware that Firefox 4 automatically saves your session when you close Firefox? The difference between "Save and Quit" and the "new" automatic save feature, is that Firefox 4 doesn't automatically load the previous session the next time, you have to use Restore Previous Session from either History > Restore Previous Session or the hyperlink on the default about:home homepage.

ladysadie 0 solutions 1 answers

Tony E. I was almost frightened away by the warning, but followed your directions anyway, and found two of the lines requiring correction as you said. I had complete success in the process. Thank you. Bill

Modified by ladysadie

mwburden 0 solutions 1 answers

Following TonyE's instructions (make sure you set all FOUR of the options he mentions to "True") got me back to the old "Save & Quit" behavior.

It's nice that it saves anyway, but that's only useful if I remember that there was something I wanted to come back to (which I might not, if it's a couple days between when I close FireFox and when I open it again.)

Modified by mwburden

alexpage 0 solutions 1 answers

I know this was months ago, but I want to point out a consequence that nobody has mentioned. Ctrl-W is used to close tabs. Ctrl-Q is used to quit. These keys are right next to each other. In old versions, the "Quit Firefox" dialog box saved you from accidentally quitting if you fat-fingered Q when you were really just meaning to close a tab. Now, your whole browser suddenly quits without warning, including all windows and tabs, even if you have "warn me when closing multiple tabs" checked in the Preferences. If you're filling out a form when this happens, it doesn't matter that you can restore your tabs after the browser restarts. You just lost everything you had typed so far. I understand that the fix is simple, but this is still very poor default behavior and the "warn me when..." preference is misleading (i.e. it doesn't actually work).

cmaye 0 solutions 1 answers

Thanks so much. This is the first proper techy thing I have ever done on my mac and it was so straightforward and easy.

mrpirate461 0 solutions 1 answers

In response to the-edmeister:

Yes, that may be the case, but what happens when you forget to click it? Say, you have 15 tabs of webcomics that you just closed. You open Firefox to check Wikipedia quickly then close it again... then realize what you just did and pound your head on the desk in frustration.

That's why Save and Exit matters.

firejolt 0 solutions 3 answers

@ BlossomingContradiction ~

find older versions of firefox here: http://www.oldapps.com/firefox.php hope this helps. currently, I am using 3.8.20 due to this same issue and found that site I just listed. However, I would prefer to use a newer version and will be trying out some of the other suggestions our other comrades have made on this forum.

cheers,

firejolt

firejolt 0 solutions 3 answers

Thank you SOOO much, TonyE!!!

It is so great to be a part of forums where we have more knowledgeable techs, like yourself available who participate in discussions that many of us (like me!) who may not know how to find solutions for certain aspects of correcting something like this.

Did what you suggested w/ the about:config ~ worked perfectly! I did notice now w/ the latest Firefox v. 6.0 that I only had to reset 2 of the 4 perimeters though. They were Browser.ShowQuitWarning and Browser.WarnOnRestart. Double-clicked on those, tried it out and presto ~ our favorite little "Save and Quit" window popped up.

Thank you, TonyE!!!

It's a shame that Firefox didn't at least make the announcement readily available for all of us to be aware of, because like most...this is a great feature that most have enjoyed and look forward to having the convenience. Btw ~ this msg to the Firefox team....you could'a told us and/or offered the same solutions that our good bud TonyE did. You can do better than that, and suggest you put up the info on your website, showing instructions or better yet, just have your team reinstall the defaults to bring up the much desired feature: "Save and Quit" window again in your new versions!

But until Firefox does actually 'listen and act' on our situations/frustrations with their browser, at least we have these forums to help guide us through. Thank God for forums!

Filos 0 solutions 1 answers

Hello,

The solution of @TonyE, it's very good, BUT don't forget to modify from menu bar in TOOLS - OPTIONS - and the GENERAL tab, when Firefox starts - "show my home page" or "show a blank page" !! (do not let "show my windows and tabs from last time")

After that "Do you want Firefox to save your tabs for the next time it starts?" it will appear. I hope this can be a good answer for somebody

Modified by Filos

123rubberduck 0 solutions 1 answers

i went on to about:config and followed all 4 steps but they where all already true. Also the browser.showQuitWarning was not on the list, i still do not get the save and quit message when quiting firefox. Do you have any suggestions.