X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox will not open after new update; Error: Platform version ‘1.9.2.13’ is not compatible

Posted

After accepting the new update I got this error message when trying to restart Firefox:

XULRunner

Error: Platform version ‘1.9.2.13’ is not compatible with minVersion >= 1.9.2.14 maxVersion <= 1.9.2.14

I have tried: - Opening in Safe Mode; same error - Uninstalling, deleting remaining info in C>ProgramFiles>MozillaFirefox folder, and reinstalling. - Updating Avast antivirus in case that was interfering.

Now when I try to start Firefox I get this message;

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

But there is nothing happening in the Windows Task Manager. Please, somebody save me from Windows Internet Explorer!!

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to V 1.9.2.14

Application

  • User Agent:

More Information

shorty2434 0 solutions 4 answers

http://support.mozilla.com/pa-IN/questions/788110

Also found this: http://forum.lowyat.net/topic/1675109

Modified by shorty2434

Question owner

Hmm, the first article suggests a clean reinstall, which I've already tried. The second regards a problem with the platform.ini file, but the contents of mine look normal (to me!); [Build] BuildID=20110218125750 Milestone=1.9.2.14 SourceStamp=a73120a6aa93 SourceRepository=http://hg.mozilla.org/releases/mozilla-1.9.2

I went to the Check your Plugins page and it said I needed to update QuickTime. While doing that I get the message; The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the installation package ‘QuickTime.msi’ in the box below.

when I click OK it says; The path ‘C:/Documents and Settings/User/Local Settings/Application Data/Apple/Apple Software Update/QuickTime.msi’ cannot be found. Verify that you have access to this location and try again, or try to find the installation package ‘QuickTime.msi’ in a folder from which you can install the product QuickTime.

I've run a search and can't find QuickTime.msi I also can't uninstall QuickTime using Add or Remove programs - I get this message; The installation source for this product is not available. Verify that the source exists and that you can access it.

Question owner

I resolved the Firefox problem using the Profile Manager and making a new profile

https://support.mozilla.com/en-US/kb/Managing%20profiles?s=Managing+profiles&as=s

After this I was able to open firefox using the new profile. It seems I have problems with my Default Profile. Probably messed it up myself trying to do a 'clean' install incorrectly.

Modified by mez_photo

cbates 0 solutions 2 answers

Helpful Reply

Hi! I received the same error as you, guys :

XULRunner

Error: Platform version ‘1.9.2.13’ is not compatible with minVersion >= 1.9.2.14 maxVersion <= 1.9.2.14

I resolved it very easy:

In the mozilla firefox folder go to platform.ini file, open the file and where is written "Milestone=1.9.2.13" change 13 with 14.

That's it!

Question owner

I know of some cases where this has worked but if you check my log file in the second reply it already says .14 so that wasn't the problem in this case.

Question owner

Might help some other people though so thanks.

cbates 0 solutions 2 answers

Did you try that after reinstaling?

Modified by cbates

dos_survivor 0 solutions 4 answers

Helpful Reply

I experienced this error updating from Firefox 3.6.13 to 3.6.14 and resolved it by doing a 'clean' install' as described. It occurred again in updating from 3.6.14 to 3.6.15 and this time a clean install failed to rectify it. (Anyway, I don't want to have to go through this every time.)

Work-around: Shut down Firefox. Edit application.ini (typically "C:\Program Files\Mozilla Firefox\application.ini")


[Gecko] MinVersion=1.9.2.15


Change to 1.9.2.13 Save. Start Firefox. Dirty? Yes. Works? Yes. (Gecko is the forerunner or XULrunner)

Question owner

Yes, it was after reinstalling that I checked platform.ini file and it looked ok. Think I probably messed up the default profile when trying to do a clean install. So maybe if I'd tried your solution first it would have worked...? Bummer because I lost all my profile info and had to start again. Glad I use the StumbleUpon Add-on; it saved all the sites I'd previously 'liked'.

Question owner

dos_survivor thanks, will try that if it does the same for the next upgrade! Got any suggestions for my QuickTime problem?

dos_survivor 0 solutions 4 answers

mez_photo, QuickTime problem (this is probably a new thread?), you could try:

Download and install latest QuickTime http://www.apple.com/quicktime/

Apple Support Topic: quicktime.msi missing http://discussions.apple.com/thread.jspa?messageID=12043942

Microsoft Support: troubleshoot problems ... install, uninstall a program.. http://support.microsoft.com/kb/2438651

Modified by dos_survivor

dos_survivor 0 solutions 4 answers

Check your plugins and either make sure they are up to date or disable before allowing Firefox updates to run:

Tools/AddOns/Plugins or http://www.mozilla.com/en-US/plugincheck/

If Firefox throws the XULRunner error or crashes, try installing the latest versions of those of the following that you have installed (use Safari, IE, Chrome or whatever) - this appears to update the relevant Firefox plugins. There may be others:

dos_survivor 0 solutions 4 answers

Thanks to Plugin7 for this - it worked for me on two machines:

"If you are running Zone Alarm Extreme Security Ver 9....... onwards with browser protection operating then go into browser security, settings, enter advanced and clear the virtual data at the bottom of page. exit and your version of firefox should work. Cheers Plugin7 "