Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The new application for Firefox is not mountin on my mac osx?

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by TonyE

more options

I have tried repeatedly to mount the new Firefox on my mac. The cache has been cleared. Cookies enabled. What else can I try? I have the original IMac.

All Replies (1)

more options

What version of OS X do you have?

Starting with Firefox 3 the minimum requirement is OS X 10.4, and for Firefox 4 it will be OS X 10.5 and an Intel Mac.

If you have OS X 10.2 - 10.3.9 the last version of Firefox that you can use is Firefox 2.0.0.20, available from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/en-US/