Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I try to load the updated version it says I do not have sufficient priviledges for some of the items

  • 3 replies
  • 2 have this problem
  • 5 views
  • Last reply by cor-el

more options

I have used Foxfire for some time. Recently, the screen prompts me to download a newer version. When I try to do so, and move the icon to the Application file, it says an older version exists and do I want to replace. I say yes and then get the message that I do not have sufficient priviledges for some items.

All Replies (3)

more options

Please try to perform a manual install: How to download and install Firefox on Mac

Does that work?

more options

I tried again but may not understand how to "manually" install, as I went through the same process of downloading the file, moving to applications and then got the same messages. (This file exists, do you want to replace and then You do not have sufficient privileges for some of the applications.)

How would I manually load it, since I have to access it from the web?

more options
  • Download a new copy of the Firefox program: http://www.mozilla.com/firefox/all.html
  • Trash the current Firefox application to do a clean (re)install.
  • Install the new version that you have downloaded.

Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data.