X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox does not ask to save tabs on exit and display them on restart.

Posted

Closing a FF4 session with multiple tabs, I am not asked to save tabs and so they don't redisplay upon restart.

In Tools-Options-Privacy I have unchecked Remember my browsing history Clear history when Firefox closes

The other options there are checked.

In Tools-Options-Tabs I have checked Warn me when closing multiple tabs.

Are my settings incorrect? Basically I want any open tabs to be reopened across sessions, but I don't want any other history to be retained.

Chosen solution

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 2 preferences browser.warnOnQuit, browser.warnOnRestart
  5. Starting with beta 12 there will be an additional preference that needs to be set to true - browser.showQuitWarning
Read this answer in context 646

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed FF4

Installed Plug-ins

  • 4.0.51204.0
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

More Information

Application Basics
Name
Firefox
Version
4.0b11
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Feedback
1.0.4
true
testpilot@labs.mozilla.com
Norton IPS
2.0
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Norton Toolbar
4.6
false
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage
www.cnn.com
browser.startup.homepage_override.buildID
20110203141415
browser.startup.homepage_override.mstone
rv:2.0b11
extensions.lastAppVersion
4.0b11
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1298392520
places.history.enabled
false
places.history.expiration.transient_current_max_pages
103545
privacy.clearOnShutdown.cache
false
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.downloads
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.history
false
privacy.clearOnShutdown.sessions
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) Q45/Q43 Express Chipset
Vendor ID
8086
Device ID
2e12
Adapter RAM
Unknown
Adapter Drivers
igdumdx32 igd10umd32
Driver Version
8.15.10.2202
Driver Date
8-25-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7600.16699, font cache n/a)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
1/1 Direct3D 10

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 2 preferences browser.warnOnQuit, browser.warnOnRestart
  5. Starting with beta 12 there will be an additional preference that needs to be set to true - browser.showQuitWarning

Question owner

Thank you for your reply, which will get me the warning messages. Presumably I'd have to reenter these commands with each beta release until final.

But will it save my tabs so they'll appear when I reopen Firefox again? That's mainly what I'm looking for here. Currently with each new session, I'm not seeing the tabs I left open in the immediately prior session.

Question owner

TonyE, PROBLEM SOLVED.

I made your changes (the first was already set to true, I changed the 2nd and 3rd from false to true), and it solved the problem. I am receiving the "Save Tabs" message now upon closing FF4, AND seeing my saved tabs in my next FF4 session.

Many thanks!

msilvers50

Mathlol1 0 solutions 3 answers

Helpful Reply

This was a very nice feature in firefox. It should automatically be set to true. On first action of its type the user can click 'do not ask again' and choose his action / stick to the pop-up each time.

EgoMrEd 0 solutions 1 answers

TonyE that was the solution! Finally I have my tabs back in beta release!!!

In linux this is not happening, just in Windows 7. I hope will not happen y final release for Windows.

Ali 0 solutions 2 answers

thanks

AikFF 0 solutions 2 answers

Hello, I tried, all values are true, yet closing the page is done without warning. Can it be that some add-in apps cause it?

Thanks Arik

mmcat17 0 solutions 1 answers

it works after i follow the instructions, but i think it should be set as true by default when you install the program, just like FF3

littleshultz 0 solutions 1 answers

Tank you it works. You are the greatest.

zapp626 0 solutions 1 answers

Sorry but your solutions doesn't help me. I set everything as you said, also I set "remember session and tabs" in the settings, still nothing helps. (I also tried creating a new profile, still no luck)

Intersting thing is: The App-Tabs are remembered, only the normal tabs not. I guess it's a bug and a really annoying one. For now Panorama is completly useless to me because the tabs won't be remembered.

Any more ideas?

AikFF 0 solutions 2 answers

Hi, Sorry but mmcat17 answer was not helpful, I followed TonyE's instructions and the tabs are close all at once without warning as it should. Probably all are set as true by default as mmcat17 mentioned, because I did not do any changes. Any other suggestions?

arameo 0 solutions 1 answers

Hi, Thanks for your suggestions. I have followed all your recommendations. However, the problem persists: when I close Firefox 4 no warning message appears, and the tabs I used during the last session do not appear when I reopen the browser. Is there perhaps something else I am missing?

Thank you for your support!

rudytome 0 solutions 1 answers

Thanks, TonyE. Worked like a charm. Howver, I agree that this should be the default settings for FF4 with an option to turn it off if I don't want it.

silversolara 0 solutions 5 answers

This didn't work for me...any suggestions?

delhirasopink 0 solutions 2 answers

The new version doesn't show save option.If you want to save your session then do this: Go to File - and then click on Exit. Its so simple. So next time when you want to open your previous session go to History and click on restore previous session. And its done.;)

Steev08 0 solutions 1 answers

Just go to File > Options > Options > General Tab > When firefox Starts > Select "Show my windows and tabs from last time"

Aufbeschissener Kunde 0 solutions 11 answers

This is so asinine! I went to close Firefox, saw a warning about closing multiple tabs, and as a creature of habit, thinking the warning was offering to remember my tabs, as it always had, I clicked "okay, close," expecting all my tabs to be restored when I restarted. But no! They weren't!

Asking to remember tabs is no longer the default option? Not even once with the option of "never ask me this question again"?! Well, sometimes I do want Firefox to remember my tabs, and sometimes I don't; I usually do want Firefox to reopen the tabs I last had open, but often times I actually want Firefox to start up fresh without reloading the few dozen tabs from my last session -- without me having to manually close each one before I quit. (Yeah, I know about private browsing which never remembers your last tabs, but that is not the issue here.)

I next found my way here, found the above stated solution and implemented it. I not only double, but triple-checked to make sure I set all the mentioned settings to true... Sure, it now remembers the tabs I last had opened, but now it never warns me before quitting while I have multiple tabs open. This is especially infuriating because I work with two monitors, and so sometimes I don't realize that Firefox has focus when I press Alt-F4 to close some other program. This means I have to restart Firefox and wait for it to reload before I can do anything, hope that form data wasn't lost, and, oh, I was in the middle of debugging a webpage that's designed to NOT cache, so the unique state I was examining won't be there when the page reloads.

This has been one damned unproductive day, all because I decided to upgrade to firefox 4.

Tito Lits 0 solutions 1 answers

Thanks. Did the suggested changes- problem solved. :)

iqubalcool 0 solutions 1 answers

Best solution

Socapex 0 solutions 4 answers

The only item I needed to change to enable the original FF3 behavior was to set browser.showQuitWarning to true (from false). FF4 now asks if you want to save your tabs just like FF3.

All of the other aforesaid settings were still at the default setting: browser.tabs.warnOnClose = true browser.warnOnQuit = true browser.warnOnRestart = false

FF4 build 20110318052756