X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox does not ask to save tabs on exit and display them on restart.

Posted

Closing a FF4 session with multiple tabs, I am not asked to save tabs and so they don't redisplay upon restart.

In Tools-Options-Privacy I have unchecked Remember my browsing history Clear history when Firefox closes

The other options there are checked.

In Tools-Options-Tabs I have checked Warn me when closing multiple tabs.

Are my settings incorrect? Basically I want any open tabs to be reopened across sessions, but I don't want any other history to be retained.

Chosen solution

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 2 preferences browser.warnOnQuit, browser.warnOnRestart
  5. Starting with beta 12 there will be an additional preference that needs to be set to true - browser.showQuitWarning
Read this answer in context 646

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed FF4

Installed Plug-ins

  • 4.0.51204.0
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

More Information

Application Basics
Name
Firefox
Version
4.0b11
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Feedback
1.0.4
true
testpilot@labs.mozilla.com
Norton IPS
2.0
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Norton Toolbar
4.6
false
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage
www.cnn.com
browser.startup.homepage_override.buildID
20110203141415
browser.startup.homepage_override.mstone
rv:2.0b11
extensions.lastAppVersion
4.0b11
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1298392520
places.history.enabled
false
places.history.expiration.transient_current_max_pages
103545
privacy.clearOnShutdown.cache
false
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.downloads
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.history
false
privacy.clearOnShutdown.sessions
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) Q45/Q43 Express Chipset
Vendor ID
8086
Device ID
2e12
Adapter RAM
Unknown
Adapter Drivers
igdumdx32 igd10umd32
Driver Version
8.15.10.2202
Driver Date
8-25-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7600.16699, font cache n/a)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
1/1 Direct3D 10

riderplus 0 solutions 1 answers

I might be wrong, but there's an option via Edit => Preferences => General => Startup => When firefox starts: (set to) Show my windows and tabs from last time

which works as 'default'.

richronn1 0 solutions 1 answers

Worked as advertised!!

skipnicholson 0 solutions 1 answers

Works perfect. Thanks, Tony. You're the best!

bricko 0 solutions 4 answers

Have done ALL of the above...and none work. All were already set per your notes. Was working fine while I read some web sites. Went to close and no longer will have the option to save. Checked all the ABOUT section in the config file. All set as supposed to be. General tab is set right.

Still nothing. What have you done. Quit messing with stuff. Put back so it defaults to Save tabs.

Tofun 0 solutions 1 answers

Before you change the config settings as adviced by Solution Chosen by msilvers50, you have to go to Options---Privacy---History and select REMEMBER HISTORY. If you do not change the options, it won't work. I had the same problem and I changed the config setting and my options was to Never Remember History and It did not work.

adriarobi 0 solutions 4 answers

Where is the "location bar"? I miss the "save tabs" option too, sooooo much!

Thanks, Phyllis

adriarobi 0 solutions 4 answers

If you go to the "History" option on the menu at the top of the screen, it gives the option to "Restore Previous Session".

Hope this helps.

Phyllis

Mugzi 0 solutions 7 answers

I have this problem as well.. Anyone figure out how to fix this??

adriarobi 0 solutions 4 answers

I have now been going to "History" on the very top menu. There is an option "Restore Previous Session", and that works great.

It is easier, and less of a chance to damage your settings. Try it, it works! :)

Phyllis

NashBash 0 solutions 1 answers

For Windows, here's the solution (took me forever to find this too...and yes, Save-tabs-on-exit is a great feature....so it's nice to know how to reset it in FF6)....

http://support.mozilla.com/en-US/kb/Session%20Restore#w_when-youve-set-firefox-to-show-your-windows-and-tabs-from-last-time

FFHelp 0 solutions 1 answers

(in case the menu bar is hidden) Press ALT > Tools > Options > General > When firefox Starts > Select "Show my windows and tabs from last time" > Enjoy!

batvans46 0 solutions 1 answers

For users running Windows 7 and experiencing the problem where even after going through all the above steps, the about:config settings are all correct and history settings are correct, and it still doesn't work...

Check whether another user is logged onto the computer. This can be the root of your problem, as it was for me. If so, hopefully you're an administrator. If you are, you can

  1. Open Task Manager (ctrl+shift+esc)
  2. Click Processes Tab
  3. At the bottom, check "show processes from all users"
  4. Click on the Users Tab
  5. Right Click on a username other than your own.
  6. Click "Log off" (Warning: Doing so will lose any unsaved data on that account, just like shutting the computer down would. I'm not responsible for anything you do, especially if you get a stapler to the head from a coworker...)
  7. Repeat for any other accounts logged in, again, other than your own. Previous warning still applies.
  8. Open Firefox, test to see it's working.


I figured this out after exhausting all the options, then went to shut down the computer in frustration and realized that my subcontractor was still logged in. Silly me, accidentally switched users instead of logging him off. .brain { onClose: lightbulb; } Hope this helps someone.

Modified by batvans46

ferlopalv 0 solutions 1 answers

After applying all the solutions cited here and none of them works 100 % , I installed Session Manager Add-on for Firefox, and now it is working fine