Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Suddenly, I cannot see pictures or icons on webpages with Firefox but can see all OK on Explorer...help, I prefer to use Firefox!

  • 2 replies
  • 36 have this problem
  • 166 views
  • Last reply by finyin

more options

Suddenly lost pictures, icons on Firefox webpages for all my usual sites that I use and visit. I can view videos on-line though. Re-downloading Firefox did not fix this problem. I can see everything normally on Internet Explorer webpages. Any idea on a fix for Firefox?

Found a solution and also had a great suggestion from another member; hope one of these solutions will work for the two other people who suddenly can't see their Firefox images on web pages.

Modified by finyin

All Replies (2)

more options

Did you check the image settings?

  • http://kb.mozillazine.org/Images_or_animations_do_not_load
  • You can see image settings in Tools > Options > Content: Load Images
  • You can see all exceptions in Tools > Options > Content: Load Images > Exceptions
  • You can see the permissions for the domain in the current tab in Tools > Page Info > Permissions
  • You can check the Tools > Page Info > Media tab for blocked images (scroll through all the images)
more options

Turns out that a simple fix was all that was needed. Somehow, without me doing this, the box for "automatically load pictures" was unchecked. I corrected the problem, closed and restarted Firefox and am so glad to say and grateful for the tip received about getting images going again, that all is running fast and is whole again!