X
Tap here to go to the mobile version of the site.

Support Forum

Disable Command-Q Shortcut

Posted

Could Mozilla please, please add an option to either A) Disable COMMAND-Q as the Keyboard Shortcut to Quit; or B) add a warning, similar to the "Closing multiple tabs" warning, that asks if you really want to quit when you press this combination?

I can't tell you how many times I've hit CMD-Q when I meant CMD-W or CMD-A, closing the whole program with no warning, losing downloads in progress, losing important open tabs that had to be re-logged in, slowing down my computer, etc.

I tried modifying the combination in OS X's Keyboard Shortcut Preferences, but although this works on other applications, CMD-Q STILL quits Firefox even with this modification.

Please add this as a preference or an add-on! I think if you Google Search, you will find many, many other Firefox users with this issue!

Could Mozilla please, please add an option to either A) Disable COMMAND-Q as the Keyboard Shortcut to Quit; or B) add a warning, similar to the "Closing multiple tabs" warning, that asks if you really want to quit when you press this combination? I can't tell you how many times I've hit CMD-Q when I meant CMD-W or CMD-A, closing the whole program with no warning, losing downloads in progress, losing important open tabs that had to be re-logged in, slowing down my computer, etc. I tried modifying the combination in OS X's Keyboard Shortcut Preferences, but although this works on other applications, CMD-Q STILL quits Firefox even with this modification. Please add this as a preference or an add-on! I think if you Google Search, you will find many, many other Firefox users with this issue!

Modified by mooseboy

Additional System Details

This happened

A few times a week

Installed Plug-ins

  • Displays PDF documents in the browser.
  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • npmnqmp 071503000004
  • VLC media player - version 1.0.0-rc4 Goldeneye - (c) 1996-2009 the VideoLAN teamhttp://www.videolan.org
  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Browser Plug-In: Plays DivX video in your browser!
  • Coupons Inc Bricks Safari Plugin
  • iPhoto6
  • Google Updater One-Click Install plugin.
  • Google Updater One-Click Deluxe Install plugin
  • Yahoo! Installer Plug-in provides application installation support
  • RealPlayer Plugin
  • Shockwave for Director 11.5.9r615
  • Office Live Update v1.0
  • Java Plug-In 2 for NPAPI Browsers
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 4.0.51204.0
  • Shockwave Flash 10.2 r152
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

dynamite 60 solutions 387 answers

There are several ways to deal with this problem:

First, you should tell Firefox that whenever it starts, it should restore your previous tabs and windows. Click on Firefox menu > Preferences > General. Set "When Firefox starts" to "Show my windows and tabs from last time".

Second, verify that your browser.warnOnQuit setting is set to true. Here's how: Type about:config into the location bar and press enter. You will see a warning message. Click on the "I'll be careful" button. You will see a list of preferences. Then, in the "Filter" box, type warnOnQuit. Check that the value of browser.warnOnQuit is set to true. If it is not, double click on it to set it to true.

Thirdly, there are several add-ons that you can install to control the behavior when you press Command-Q. For example, always-ask and session-manager.

There are several ways to deal with this problem: First, you should tell Firefox that whenever it starts, it should restore your previous tabs and windows. Click on Firefox menu > Preferences > General. Set "When Firefox starts" to "Show my windows and tabs from last time". Second, verify that your browser.warnOnQuit setting is set to true. Here's how: Type '''about:config''' into the location bar and press enter. You will see a warning message. Click on the "I'll be careful" button. You will see a list of preferences. Then, in the "Filter" box, type '''warnOnQuit'''. Check that the value of browser.warnOnQuit is set to true. If it is not, double click on it to set it to true. Thirdly, there are several add-ons that you can install to control the behavior when you press Command-Q. For example, [https://addons.mozilla.org/en-US/firefox/addon/always-ask/ always-ask] and [https://addons.mozilla.org/en-US/firefox/addon/session-manager session-manager].

Modified by dynamite

fahree 0 solutions 1 answers

Helpful Reply

Firefox wouldn't let me toggle the browser.warnOnQuit setting in about:config, but from http://hints.macworld.com/article.php?story=2003050112482698 I got this trick that reassigns 'Quit Firefox' to Command-Shift-Q:

defaults write NSGlobalDomain NSUserKeyEquivalents '{"Quit Firefox" = "@$Q";}'

Firefox wouldn't let me toggle the browser.warnOnQuit setting in about:config, but from http://hints.macworld.com/article.php?story=2003050112482698 I got this trick that reassigns 'Quit Firefox' to Command-Shift-Q: defaults write NSGlobalDomain NSUserKeyEquivalents '{"Quit Firefox" = "@$Q";}'

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
12134 solutions 112710 answers
See also: *http://www.mactipper.com/2008/03/add-keyboard-shortcuts-for-applications.html
haridsv 0 solutions 1 answers

For some reason the "default write" solution didn't work for me (I also tried some variants suggested in the macworld article), but one thing that worked well is to install keyconfig and change the shortcut for "Quit Firefox". I actually had this working a few weeks back and when I upgraded Firefox, I disabled some extensions during the upgrade process, and one of those was keyconfig, which brought the problem back. I can 100% confirm that if I disable keyconfig and restart Firefox, the problem comes back, so it does work.

For some reason the "default write" solution didn't work for me (I also tried some variants suggested in the macworld article), but one thing that worked well is to install keyconfig and change the shortcut for "Quit Firefox". I actually had this working a few weeks back and when I upgraded Firefox, I disabled some extensions during the upgrade process, and one of those was keyconfig, which brought the problem back. I can 100% confirm that if I disable keyconfig and restart Firefox, the problem comes back, so it does work.