X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox overriding CSS values for link colors

Posted

bsucatalyst.com/index.php

All hyperlinked images are appearing with a linked border-style colorization. Border-style should be none for all <a href="..."></a>.

a { border: none; } a:hover { border: none; } a:link { border: none; } a:visited { border: none: }


The above code is all being used. I have firebug and, even after inspecting the elements, see no properties set to display a border style, width, or color. Firefox is the ONLY browser incorrectly displaying these pages.

Additional System Details

Sites Affected

http://bsucatalyst.com/index.php

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102
  • Contribute Plug-inInbrowser Editor Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

I've tried overriding with CSS and with HTML. The only thing that makes a difference is when I go through Firefox preferences and change the color there. I have the box checked that says website are allowed to define their own colors and that those sites will override Firefox, but Firefox is obviously still overriding my webpages.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

A good place to ask questions and advice about web development is at the mozillaZine Web Development/Standards Evangelism forum.
The helpers at that forum are more knowledgeable about web development issues.
You need to register at the mozillaZine forum site in order to post at that forum.

See http://forums.mozillazine.org/viewforum.php?f=25

Question owner

Thanks a bunch Cor-El.

That forum has the answer. http://forums.mozillazine.org/viewtopic.php?f=25&t=1188135&sid=d4b70caa58ad9a482f96418087cf0ce0

basically you just have to add the following code to the CSS:

a img { border:none; }

This fixes all.