X
Tap here to go to the mobile version of the site.

Support Forum

I can't use my Mac's pinch-zoom function in Firefox 4, so I can't enlarge the text & images of websites.

Posted

I just downloaded Firefox's 4 Beta browser for my new Macbook Pro. When I try to use the pinch and zoom function of my keypad, it has no effect in Firefox 4.

I would like to be able to use this function with Firefox. Is is just not compatible with the new version 4 beta? How else can you zoom in and enlarge a web page's text & images in firefox 4?

I have already checked my keypad settings and the pinch-zoom function is turned on and works correctly on my desktop, in safari and other programs on my Mac.

I just downloaded Firefox's 4 Beta browser for my new Macbook Pro. When I try to use the pinch and zoom function of my keypad, it has no effect in Firefox 4. I would like to be able to use this function with Firefox. Is is just not compatible with the new version 4 beta? How else can you zoom in and enlarge a web page's text & images in firefox 4? I have already checked my keypad settings and the pinch-zoom function is turned on and works correctly on my desktop, in safari and other programs on my Mac.

Additional System Details

This happened

Every time Firefox opened

This started when...

This always occured

Installed Plug-ins

  • Shockwave Flash 10.1 r102
  • iPhoto6
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17165 solutions 155166 answers

Try to check the browser.gesture.pinch.* prefs on the about:config page to see if they are still set to zoom.

See http://kb.mozillazine.org/about%3Aconfig

Try to check the browser.gesture.pinch.* prefs on the about:config page to see if they are still set to zoom. See http://kb.mozillazine.org/about%3Aconfig
13B 0 solutions 1 answers

I had the same issue... originally when I installed the beta version it worked fine but then one day it stopped working. I uninstalled it, installed version 3.6 and then reinstalled the beta and it started working again.

I had the same issue... originally when I installed the beta version it worked fine but then one day it stopped working. I uninstalled it, installed version 3.6 and then reinstalled the beta and it started working again.

Modified by 13B

Question owner

Attached is a screenshot of what I see when I look at the "about:config" screen for the "browser.gesture.pinch.*" preferences.

Should I modify any of these? And if so, to what to get the pinch-zoom function working again?

Thanks for your help!

Attached is a screenshot of what I see when I look at the "about:config" screen for the "browser.gesture.pinch.*" preferences. Should I modify any of these? And if so, to what to get the pinch-zoom function working again? Thanks for your help!
cor-el
  • Top 10 Contributor
  • Moderator
17165 solutions 155166 answers

Helpful Reply

Firefox 3.6 has these values for the pinch.in and pinch.out prefs

browser.gesture.pinch.in -> cmd_fullZoomReduce
browser.gesture.pinch.in.shift -> cmd_fullZoomReset
browser.gesture.pinch.out -> cmd_fullZoomEnlarge
browser.gesture.pinch.out.shift -> cmd_fullZoomReset
Firefox 3.6 has these values for the pinch.in and pinch.out prefs <pre><nowiki>browser.gesture.pinch.in -> cmd_fullZoomReduce browser.gesture.pinch.in.shift -> cmd_fullZoomReset browser.gesture.pinch.out -> cmd_fullZoomEnlarge browser.gesture.pinch.out.shift -> cmd_fullZoomReset </nowiki></pre>

Modified by cor-el

sccthree 0 solutions 1 answers

Helpful Reply

I had the same problem and was seeing the same thing as aerlyn02's screen shot. Setting to the values posted by cor-el resolved the issue.

Open a new tab and type about:config and press enter. In the search pane type pinch and press enter. Add the values for the four settings above and you are finished. Thanks guys!

I had the same problem and was seeing the same thing as aerlyn02's screen shot. Setting to the values posted by cor-el resolved the issue. Open a new tab and type about:config and press enter. In the search pane type pinch and press enter. Add the values for the four settings above and you are finished. Thanks guys!
nborys 0 solutions 1 answers

This solution also works for Firefox 4 on Windows 7 on a tablet PC. I lost the pinch zoom functionality but regained after entering in the values specified by aerlyn02.

This solution also works for Firefox 4 on Windows 7 on a tablet PC. I lost the pinch zoom functionality but regained after entering in the values specified by aerlyn02.
Shutez 0 solutions 1 answers

Unfortunately, this doesn't FULLY fix the problem. It seems to be a bit of a workaround.

It will restore partial pinch-to-zoom functionality. For each new zoom level, you have to lift your fingers from the trackpad and "repinch" it. This is very different from apple's default pinch-to-zoom functionality that allows continuous zooming as long as the fingers are moving away from each other or toward each other.

Unfortunately, this doesn't FULLY fix the problem. It seems to be a bit of a workaround. It will restore partial pinch-to-zoom functionality. For each new zoom level, you have to lift your fingers from the trackpad and "repinch" it. This is very different from apple's default pinch-to-zoom functionality that allows continuous zooming as long as the fingers are moving away from each other or toward each other.
Soom 0 solutions 4 answers

Shutez is right - it doesn't do the same job, as it only zooms one step at a time, but not continuously. Maybe there are other values we can set for this to work?

I think it's just a small thing the Mozilla people missed - hopefully it will be fixed in an update.

Shutez is right - it doesn't do the same job, as it only zooms one step at a time, but not continuously. Maybe there are other values we can set for this to work? I think it's just a small thing the Mozilla people missed - hopefully it will be fixed in an update.
iibpmii 0 solutions 17 answers

set broswer.gesture.pinch.latched to false , it will zoom all the way, you dont have to take of your fingers :D

set broswer.gesture.pinch.latched to false , it will zoom all the way, you dont have to take of your fingers :D
genie_vn 0 solutions 1 answers
I found the solution here [http://techmix.net/blog/2011/03/26/problem-with-pinchzoom-on-firefox-4-mac-osx/ http://techmix.net/blog/2011/03/26/problem-with-pinchzoom-on-firefox-4-mac-osx/]
capacity38 0 solutions 1 answers

The about:config change did not work. Has it actually worked for anyone?

The about:config change did not work. Has it actually worked for anyone?
jesnft 0 solutions 1 answers

For Firefox 4.0, several people have provided the solutions. The solution at: [http://techmix.net/blog/2011/03/26/pr.../problem-with-pinchzoom-on-firefox-4-mac-osx/] restores Pinch-Zoom capability but with discrete steps. You also need to set browser.gesture.pinch.latched to false as was pointed out by iibpmii

So combining the steps, the complete solution that worked for me is:

  1. - Open a new Tab and type in “about:config” (without the quote) in the address bar
  2. - You will be asked to confirm to continue. Just do it.
  3. - Search for the term “browser.gesture” (without the quote).
  4. - Edit the browser.gesture.pinch settings as follows:
  • browser.gesture.pinch.in Value = cmd_fullZoomReduce
  • browser.gesture.pinch.in.shift Value = cmd_fullZoomReset
  • browser.gesture.pinch.latched Value = false
  • browser.gesture.pinch.out Value = cmd_fullZoomEnlarge
  • browser.gesture.pinch.out.shift Value = cmd_fullZoomReset
For Firefox 4.0, several people have provided the solutions. The solution at: [[http://techmix.net/blog/2011/03/26/problem-with-pinchzoom-on-firefox-4-mac-osx/|http://techmix.net/blog/2011/03/26/problem-with-pinchzoom-on-firefox-4-mac-osx/]] restores Pinch-Zoom capability but with discrete steps. You also need to set browser.gesture.pinch.latched to false as was pointed out by iibpmii So combining the steps, the complete solution that worked for me is: # - Open a new Tab and type in “about:config” (without the quote) in the address bar # - You will be asked to confirm to continue. Just do it. # - Search for the term “browser.gesture” (without the quote). # - Edit the browser.gesture.pinch settings as follows: * '''browser.gesture.pinch.in''' Value = cmd_fullZoomReduce * '''browser.gesture.pinch.in.shift''' Value = cmd_fullZoomReset * '''browser.gesture.pinch.latched Value''' = false *''' browser.gesture.pinch.out''' Value = cmd_fullZoomEnlarge *''' browser.gesture.pinch.out.shift''' Value = cmd_fullZoomReset
bigturnip 0 solutions 1 answers

I also find it a lot better if you change browser.gesture.pinch.threshold to 50 rather than the default 150, it makes it a lot smoother and you can zoom further in one pinch.

I also find it a lot better if you change '''browser.gesture.pinch.threshold''' to '''50''' rather than the default '''150''', it makes it a lot smoother and you can zoom further in one pinch.

Modified by bigturnip

jabobinski 0 solutions 1 answers

You can go to the firefox website go to the tab add-ons go down to extentions type in the search bar pinch zoom and download the pinch add-on or search pinchy. it works for now til firefox can fix the problem.

You can go to the firefox website go to the tab add-ons go down to extentions type in the search bar pinch zoom and download the pinch add-on or search pinchy. it works for now til firefox can fix the problem.
unkabuzz 0 solutions 5 answers

Interesting... The "Pinch Threshold" on my Lenovo S-10 3T Netbook/Tablet running windows 7 Home Premium was set to 25 by default....

 I tried several times to change the other values in these posts and had no response on my touchscreen what-so-ever. So I downloaded Google chrome and transferred my bookmarks to it. Then I  completely deleted Firefox and re-downloaded 3.6.17 and all is well again.
Interesting... The "Pinch Threshold" on my Lenovo S-10 3T Netbook/Tablet running windows 7 Home Premium was set to 25 by default.... I tried several times to change the other values in these posts and had no response on my touchscreen what-so-ever. So I downloaded Google chrome and transferred my bookmarks to it. Then I completely deleted Firefox and re-downloaded 3.6.17 and all is well again.

Modified by unkabuzz

unkabuzz 0 solutions 5 answers

Does anybody in an "official" position know if Firefox 5 (due for release June 21st) will have the pinch zoom feature fixed??

Does anybody in an "official" position know if Firefox 5 (due for release June 21st) will have the pinch zoom feature fixed??
cor-el
  • Top 10 Contributor
  • Moderator
17165 solutions 155166 answers

No, that won't be 'fixed' in Firefox 5.
The removal was done on purpose and won't be reverted.


  • Bug 613909 - Disable pinch gestures by default & revert three finger vertical swipe gestures
  • Bug 632733 - Make it possible to enable "pinch to zoom" in Preferences

(please do not comment in bug reports; you can vote instead)

No, that won't be 'fixed' in Firefox 5.<br /> The removal was done on purpose and won't be reverted. ---- *[https://bugzilla.mozilla.org/show_bug.cgi?id=613909 Bug 613909] - Disable pinch gestures by default & revert three finger vertical swipe gestures *[https://bugzilla.mozilla.org/show_bug.cgi?id=632733 Bug 632733] - Make it possible to enable "pinch to zoom" in Preferences ''(please do not comment in bug reports; you can vote instead)''
unkabuzz 0 solutions 5 answers

Any idea "why" it was removed in the first place???

Any idea "why" it was removed in the first place???
unkabuzz 0 solutions 5 answers

I had real trouble changing the values properly (partly my fault) in FF4. Gave up and went back to 3.6.17. Just had to try FF5 (Just released). Changed the values in it and pinch zoom is working perfectly. The following is "all" that you need to change...

cmd_fullZoomReduce

cmd_fullZoomReset

cmd_fullZoomEnlarge

cmd_fullZoomReset

I had real trouble changing the values properly (partly my fault) in FF4. Gave up and went back to 3.6.17. Just had to try FF5 (Just released). Changed the values in it and pinch zoom is working perfectly. The following is "all" that you need to change... cmd_fullZoomReduce cmd_fullZoomReset cmd_fullZoomEnlarge cmd_fullZoomReset

Modified by unkabuzz

Combi 0 solutions 1 answers

I entered the values and changed the latch command for FF5 on my mac, no need to take the fingers off the track pad. I uploaded a shot of what "about config" should look like to make Firefox work with the pinch function/gesture. Remember, set .latched to "false" and .threshold to a lower number like 50 if you want a smoother zoom with more range. Personally, I went from 150 to 80, 50 is too sensitive for me.

I entered the values and changed the latch command for FF5 on my mac, no need to take the fingers off the track pad. I uploaded a shot of what "about config" should look like to make Firefox work with the pinch function/gesture. Remember, set .latched to "false" and .threshold to a lower number like 50 if you want a smoother zoom with more range. Personally, I went from 150 to 80, 50 is too sensitive for me.

Modified by Combi