X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop videos loading automatically, please ?

Posted

I like looking at news sites but I find it very annoying when there's a video that starts playing almost immediately, for example, http://www.bbc.co.uk/news/science-environment-12199980

or a podcast, for example, http://news.bbc.co.uk/today/hi/today/newsid_9361000/9361254.stm

Ideally, I would like to be able to change settings so that neither videos no podcasts start until I'm ready for them.

How can I achieve this ?

Chosen solution

Additional System Details

Installed Plug-ins

  • getplusplusadobe16263
  • Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • ScorchPlugin
  • DjVu Plug-In(external version 6.1.4.2013)
  • getpluscorel15048
  • Adobe PDF Plug-In For Firefox and Netscape
  • Express View Browser Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 10.2
  • np-mswmp
  • Shockwave Flash 10.1 r102
  • GEPlugin
  • Google Updater pluginhttp://pack.google.com/
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • Google Update
  • Java Plug-in 1.6.0_02 for Netscape Navigator (DLL Helper)
  • Npdsplay dll
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.16) Gecko/20101130 Firefox/3.5.16

More Information

I'm using Firefox 3.5.16 on a PC running Windows XP

Helper7677 165 solutions 1653 answers

NoScript will help with that and more.

NoScript is a powerful extension. To allow the 2 items you posted you should "Temporarily allow bbc.co.uk" and "Temporarily allow bbcimg.co.uk". If you choose "Allow..." instead of "Temporarily allow..." those sites will be permanently added to the NoScript whitelist; "Temporarily allow..." only adds them for the current Firefox session.



Other issues that need your attention

The information submitted with your question indicates that you have out of date plugins with known security and stability issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post. You can also see your plugins from the Firefox menu, Tools > Add-ons > Plugins.

  • Adobe Shockwave for Director Netscape plug-in, version 10.2
  • Adobe PDF Plug-In For Firefox and Netscape
  • Java Plug-in 1.6.0_02 for Netscape Navigator (DLL Helper)
    • Firefox 3.6+ needs at least version 1.6.0_10
    • You are 21 revisions behind including many security updates
    • Remove the old version (see link below), download and install the new version
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
      • Use the links below to avoid getting the troublesome "getplus" Adobe Download Manager and other "extras" you may not want
      • Use Firefox to download and SAVE the installer to your hard drive from the appropriate link below
      • Click "Save to File"; save to your Desktop (so you can find it)
      • After download completes, close Firefox
      • Click the installer you just downloaded and allow the install to continue
        • Note: Vista and Win7 users may need to right-click the installer and choose "Run as Administrator"
      • Download link: ftp://ftp.adobe.com/pub/adobe/reader/
        • Choose your OS
        • Choose the latest #.x version (example 9.x, for version 9)
        • Choose the highest number version listed
          • NOTE: 10.x is the new Adobe Reader X (Windows and Mac only as of this posting)
        • Choose your language
        • Download the file, SAVE it to your hard drive, when complete, close Firefox, click on the installer you just downloaded and let it install.
        • Windows: choose the .exe file; Mac: choose the .dmg file
    • Using either of the links below will force you to install the "getPlus" Adobe Download Manager. Also be sure to uncheck the McAfee Scanner if you do not want the link forcibly installed on your desktop
    • After the installation, start Firefox and check your version again.
  4. Update the Java plugin to the latest version.

Question owner

Thanks, I will try that out.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96752 answers

Chosen Solution

You can also look at Stop Autoplay: https://addons.mozilla.org/firefox/addon/1765

Question owner

cor-el Thanks very much.

Stop Autoplay worked for me, although to stop the BBC videos playing I had to tick Block all flash media. It now shows no video picture or podcast description but at least it doesn't start the video/podcast.
tez9494 0 solutions 1 answers

Helpful Reply

I use Flashblock - it also handily stops the annoying video ads aswell

https://addons.mozilla.org/en-US/firefox/addon/flashblock/

Question owner

I've now been using Stop Autoplay for about 8 months. It works fine, though sometimes the player has to be clicked twice to play.

Also on some sites, embedded videos like those from YouTube won't play at all; however, this may not be related to Stop Autoplay at all.

I've noticed that videos in email (I'm using Outlook Express - I find it better than its replacement and Thunderbird) don't play, but I suspect that's not related.

Modified by Pertinax

mr.lauri 0 solutions 1 answers

Helpful Reply

hi there.

does anybody know an alternative to 'stop autoplay'? Been using this for long now - so convenient! Seems like it'll not be developed any further and wouldn't work for the new Fox 8.something.. any new ideas on that topic (apart from NoScript or Flashblock)?

mozmos 0 solutions 5 answers

I have got the impression there is a will NOT to have this kind of tool on Firefox!

Is Open Source openly going to be Open Business Privately Financed?


Just a thought.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96752 answers

You can try to set the media.autoplay.enabled pref to false on the about:config page, but I do not know if that works for this case as well.