X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Links in email won't open. When I click on a link, it goes to open tabs in FF, but the new link doesn't open.

Posted

When I get a link sent in an email, the link no longer opens when I click on it. When I click on the link, Firefox and the open internet tabs appear on my screen, but the new link does not open. I must manually copy the link, then paste it in the address bar to get it to open.

Additional System Details

This happened

Every time Firefox opened

This started when...

about 3 weeks ago... not sure why...

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • Coupons Inc. Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 4.0.50826.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

Ziggy Maes 0 solutions 56 answers

Hi CurlyGirl,

So Firefox opens a new tab but does not display the website or the URL in the location bar, is that right?

Regards, Ziggy

Question owner

No. It doesn't open a new tab at all, it just goes to Firefox and the tabs I already have open. (I usually have 6-10 tabs open... I does shift from the mail program to the internet when I click on the link, however.) Does this make sense?

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

You may see this bug (got resolved recently in current Minefield 4.0 nightly builds).

Bug 531552 – Firefox opens two windows when opening external links

(please do not comment in bug reports)

Question owner

Thanks. I haven't been able to get ANY window to open from a link. I tried closing the internet, then clicking on a link in email. Nothing. Even when I right click and select Open Link, nothing happens when the internet isn't already running. When it is open, the internet window becomes active, but no new windows/tabs are open with the link. Does that make sense?

Dynn 0 solutions 1 answers

This sounds like the same issue I'm having, and if it is I have something to add.

When I click a link that would normally open in a new window instead of a new tab, it opens nothing. However, after I close Firefox, it continues running, behaving as if those other windows are still open, when nothing actually is. I have to manually open the task manager and end the process to start a new Firefox session.

I'm running Windows 7, in case the issue might stem from there (which often seems to be the case with Microsoft =P ).

Question owner

I'm on a mac, and when I set Safari as my default browser, it works fine. I've been using Firefox however, and much prefer the set up of FF.

Gorf 0 solutions 1 answers

Helpful Reply

I have the same problem with FF 3.6.13, and Mac OS 10.6.5.

Clicking links in Mail opens FF, but does not open the URL. Safari has no problems when I reset it as my default browser. The problem seems to develop over time. At first, links open fine, but then all of a sudden they won't.

My remedy has been to reinstall FF, but I've had to do it twice in the last couple of weeks, which is getting a bit annoying.

I have not experienced the problem on either of my two older Macs (running 10.4, and 10.5).

Modified by Gorf

Question owner

This sounds like it will solve my issues, but I have spent a lot of time bookmarking sites and sorting them on my toolbar... Is there a way to save these so I can reinstall these after I unistall/reinstall firefox?

Thanks!

CG

veal 0 solutions 1 answers

Gorf,

I am having the exact same problem. Were you able to find any resolution to this yet?

Question owner

OK. I did that and it works... for a few days, or sometimes for a few hours. I have to go through the uninstall/reinstall several times per week. Arg. I would LOVE it if there is fix out there somewhere??? (The irony is, when I get an email that there is a response to this question, the link doesn't work.) *sigh*

graphicsteach 0 solutions 1 answers

I had this problem with FF version 3.6.10. Updated to 3.6.13 and Mac OS 10.6.6 and the bug was fixed. Links automatically open again.

aussierobbo 0 solutions 1 answers

Helpful Reply

I have the latest version of FF and Mac OS but I still have the same problem described... It only seems to have started happening in the last week.

stefanieelle 0 solutions 1 answers

I'm new to Macs and I have the same problem. I found a solution that stated:

Close Firefox Open Safari and go to the preferences In the general tab, make Safari your default browser. Go to Mail.app and make sure you can click on a link and open it in Safari. Switch the default browser back to Firefox and close Safari Go back to Mail.app and click the link. It should now open in Firefox.

But...this does not work for me. Very frustrated. I am running 10.6.6.

yarntomato 0 solutions 1 answers

I just started having this same problem today. I think I solved it by doing Software Update on my Mac.

Problem was: When I clicked a link in an email, it just went to the tabs I already had open in Firefox. It did not open a new tab for the clicked link, it simply showed the tabs I already had open. If I didn't already have Firefox open, it went to my Firefox home page.

When I did Software Update on my Mac, it installed the following updates: Safari (version 5.0.5), Security Update 2011-002 (version 1.0), and Canon Printer Software Update (version 2.5).

I wouldn't think any of those updates are related to Firefox, but the problem stopped immediately. These Software Updates did require shut down and restart. Maybe the Safari update somehow affected Firefox?

I will report back if I start having the same problem again.

Modified by yarntomato

Looc 0 solutions 1 answers

There does not appear to be any resolution to this problem. My situation is similar to Dynn - in my case using Windows 7, Thunderbird 3.1.10 and Firefox 4.01 (latest versions). Clicking on a link in an email often opens Firefox with a blank tab, but the url does not appear, nor the page open. I can copy the link and paste it to Firefox, and usually the page will open, but not always. When I close Firefox and try to open it later, I get a message that says that Firefox is still running. I have to either close down completely, or open Task Manager and stop Firefox.

Miao93 0 solutions 1 answers

Running Mac 10.6.8 and Firefox 3.6.19. SAME PROBLEM....

Hasan 477 solutions 5600 answers

Update to the Latest Firefox version - Installing Firefox on Mac

https://support.mozilla.com/en-US/kb/Installing%20Firefox%20on%20Mac

Check and tell if its working.

wteague 0 solutions 2 answers

I had similar problem, but when I clicked on the link in the email a 2nd time, then it would work.

I have set Safari to default and the gone back to Firefox and set it as default, now it works.

That seems to be it for now.

Ian Stargazer 0 solutions 1 answers

I had this problem of links not opening from emails. After reading some of the above messages, I opened Firefox, went to Tools/Options/Advanced/General. Under "system defaults" I clicked on "check now" to see if Firefox was my default browser. It wasn't, but I had the option to make it so.

I made it so, and now emailed links open a new tab as they're supposed to.

All tickadeboo : )

Also, I use Mozilla Thunderbird and had already unticked "block pop-ups", which made no difference.

Modified by Ian Stargazer